This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1029628 - PartitionException: Partition is not part of the disk it is being removed from
PartitionException: Partition is not part of the disk it is being removed from
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.0
All Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Lehman
Release Test Team
abrt_hash:a307e4d5f492c5748e9fcde04f5...
:
: 1030836 (view as bug list)
Depends On: 1027846
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 14:10 EST by David Lehman
Modified: 2014-06-18 00:45 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-blivet-0.18.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1027846
Environment:
Last Closed: 2014-06-13 09:26:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-11-12 14:10:47 EST
+++ This bug was initially created as a clone of Bug #1027846 +++

Description of problem:
Tried to manual partitioning (delete old, autopart, manual change of some settings). 	Accidentally unselected my disk,  bug appeared. after reselecting it again and returning.

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 269, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 595, in removeNewPartitions
    part.disk.format.partedDisk.removePartition(part.partedPartition)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 784, in doPartitioning
    removeNewPartitions(disks, partitions)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 320, in doAutoPartition
    doPartitioning(storage)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 263, in execute
    doAutoPartition(storage, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1740, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 429, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
PartitionException: Partition is not part of the disk it is being removed from

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta

Potential duplicate: bug 865653

--- Additional comment from Lukas Brabec on 2013-11-07 08:17:33 EST ---

1) storage -> done -> custom partitioning
2) delete (all) old and create new automatically
3) done -> accept
4) (accidentally, as used from previous Fedora) unselect disk -> done
5) select disk again -> done -> continue
Comment 1 David Lehman 2013-12-16 15:19:11 EST
*** Bug 1030836 has been marked as a duplicate of this bug. ***
Comment 3 Matti Kurkela 2014-01-24 07:14:39 EST
In the RHEL7 beta installer,
1.) Delete existing automatic RHEL7 partitioning from a disk
2.) Let the installer create a new layout (the automatic option in the partitioning dialog)

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=RHEL-7.0\x20Everything.x86_64 quiet BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.10.0-54.0.1.el7.x86_64
package:        anaconda-19.31.36-1
product:        Red Hat Enterprise Linux
reason:         PartitionException: Partition is not part of the disk it is being removed from
release:        Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)
version:        7.0
Comment 4 Jan Stodola 2014-02-14 04:17:32 EST
Reproduced with python-blivet-0.18.13-2.el7, verified with python-blivet-0.18.23-1.el7. The traceback doesn't appear and the installation is successful.

Moving to VERIFIED.
Comment 5 Ludek Smid 2014-06-13 09:26:34 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.