Bug 1028031 - Globally uncaught exception while viewing members reporting for auto-group with NaN
Globally uncaught exception while viewing members reporting for auto-group w...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
x86_64 Linux
unspecified Severity high
: ER07
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
: 1028323 1042646 (view as bug list)
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-11-07 09:03 EST by Armine Hovsepyan
Modified: 2015-09-02 20:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:33:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
globally-uncaught_ex.png (139.03 KB, image/png)
2013-11-07 09:03 EST, Armine Hovsepyan
no flags Details
exc_msg (3.93 KB, text/x-log)
2013-11-07 09:28 EST, Armine Hovsepyan
no flags Details
memberReportingNaN (136.10 KB, image/png)
2013-11-07 10:12 EST, Armine Hovsepyan
no flags Details
NaN Autogroup error (348.64 KB, image/jpeg)
2013-11-07 11:14 EST, Mike Thompson
no flags Details
metric_for_nan (143.85 KB, image/png)
2013-11-22 07:32 EST, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-11-07 09:03:30 EST
Created attachment 821155 [details]
globally-uncaught_ex.png

Description of problem:
Globally uncaught exception while viewing Metrics for  aouto-group

Version-Release number of selected component (if applicable):
jon 3.2 er5

How reproducible:
always

Steps to Reproduce:
1. Click on autogroup such as CPU
2. click monitoring tab
3. click metrics subtab
4. Click on any of members reporting  

Actual results:
Globally uncaught exception 

Expected results:
corresponding charts should be drown

Additional info:
screen-shots attached
no exception in server or agent logs

Since user is unable to view charts of auto-group resources' metrics i am marking this issue as blocker for GA
Comment 1 Armine Hovsepyan 2013-11-07 09:28:06 EST
Created attachment 821167 [details]
exc_msg
Comment 2 Armine Hovsepyan 2013-11-07 10:12:13 EST
Note: The issue is cause by having no data for member reports metrics ->  see membersReportingNaN.ong
Comment 3 Armine Hovsepyan 2013-11-07 10:12:49 EST
Created attachment 821207 [details]
memberReportingNaN
Comment 4 Mike Thompson 2013-11-07 11:14:08 EST
Created attachment 821247 [details]
NaN Autogroup error
Comment 5 Mike Thompson 2013-11-07 11:19:36 EST
The NaN values, cause a blank value for a number in the json produced in the graph . This blank value is not valid json and the d3 graph throws an error parsing the blank value where a number should be present. I'm inserting a zero for the blank value as a valid number.
Comment 6 Mike Thompson 2013-11-07 11:24:49 EST
Pushed to master as commit: 5f95176
Comment 7 Mike Thompson 2013-11-07 11:28:38 EST
Pushed to release/jon3.2.x as commit: befe0a3
Comment 8 Armine Hovsepyan 2013-11-08 07:32:48 EST
*** Bug 1028323 has been marked as a duplicate of this bug. ***
Comment 9 Simeon Pinder 2013-11-19 10:47:56 EST
Moving to ON_QA as available for testing with new brew build.
Comment 10 Simeon Pinder 2013-11-22 00:13:32 EST
Mass moving all of these from ER6 to target milestone ER07 since the ER6 build was bad and QE was halted for the same reason.
Comment 11 Armine Hovsepyan 2013-11-22 07:32:29 EST
Created attachment 827730 [details]
metric_for_nan
Comment 12 Armine Hovsepyan 2013-11-22 07:32:55 EST
verified in er7
screen-shot attached
Comment 13 Elias Ross 2013-12-12 20:13:44 EST
*** Bug 1042646 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.