Bug 1028323 - Globally uncaught exception when showing graphs on autogroup
Globally uncaught exception when showing graphs on autogroup
Status: CLOSED DUPLICATE of bug 1028031
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring -- Other (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 03:32 EST by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-08 07:32:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-11-08 03:32:32 EST
Description of problem:


Version-Release number of selected component (if applicable):
JON 3.2.ER5

How reproducible: always


Steps to Reproduce:
1. Import RHQ Server resource
2. go to rhq.ear / rhq-server.jar / ejb3 / Stateless Session Bean Runtimes autogroup
3. set collection time all schedules to 1m
4. switch to metrics and click on any having some NaN in Minimum/Maximum/Average columns

Actual results: No graph is displayed, uncaught exception raises

fileName: http://jon32-server.bc.jonqe.lab.eng.bos.redhat.com:7080/coregui/js/jquery-1.7.2.min.js
 lineNumber: 2
 columnNumber: 10806: JSON.parse: unexpected character
   at Unknown.f</<.parseJSON(Unknown Source)
   at Unknown.$drawJsniChart_1/MultiLineChartContext(Unknown Source)
   at Unknown.$drawJsniChart_1(Unknown Source)
   at Unknown.run_22(Unknown Source)

Expected results: graph i shown the as if having no NaN values



Additional info:
Comment 1 Armine Hovsepyan 2013-11-08 07:32:48 EST

*** This bug has been marked as a duplicate of bug 1028031 ***

Note You need to log in before you can comment on or make changes to this bug.