Bug 1028281 - Create Volume: No systems root partition error when script mode
Create Volume: No systems root partition error when script mode
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
:
Depends On:
Blocks: 1028282
  Show dependency treegraph
 
Reported: 2013-11-08 00:39 EST by Aravinda VK
Modified: 2014-11-11 03:24 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1028282 (view as bug list)
Environment:
Last Closed: 2014-11-11 03:24:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2013-11-08 00:39:10 EST
Description of problem:
When we try to create volume with bricks in root partition, gluster cli will give following error. But it creates volume successfully in script mode.

gluster volume create gv1 sumne.sumne:/gfs/gv1_b1 sumne.sumne:/gfs/gv1_b2

volume create: gv1: failed: The brick sumne.sumne:/gfs/gv1_b1 is is being created in the root partition. It is recommended that you don't use the system's root partition for storage backend. Or use 'force' at the end of the command if you want to override this behavior.


How reproducible:
100%

Steps to Reproduce:
1. Create volume with bricks dir in root partition
gluster volume create gv1 sumne.sumne:/gfs/gv1_b1 sumne.sumne:/gfs/gv1_b2
It will fail with above mentioned error
2. Create volume with script mode
gluster volume create gv1 sumne.sumne:/gfs/gv1_b1 sumne.sumne:/gfs/gv1_b2 --mode=script
Creates volume successfully.

Actual results:
Creates volume successfully without any error.

Expected results:
Script mode should fail if brick dirs are system's root partition.
Comment 1 Anand Avati 2013-12-03 05:18:10 EST
REVIEW: http://review.gluster.org/6409 (cli: Fail creation of bricks on root partition in script mode) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Anand Avati 2013-12-04 16:42:04 EST
COMMIT: http://review.gluster.org/6409 committed in master by Anand Avati (avati@redhat.com) 
------
commit def8890d5ea7e73dfa37023e5d324be0bc289f5a
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Dec 2 11:37:55 2013 +0530

    cli: Fail creation of bricks on root partition in script mode
    
    Also added an option 'wignore' to save ourselves the trouble
    of modifying test scripts in our regression test suite as well
    as those that are still under review.
    
    Change-Id: Id320c03595506e9da187e766991c19640bd000c5
    BUG: 1028281
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: http://review.gluster.org/6409
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Niels de Vos 2014-09-22 08:32:36 EDT
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 4 Niels de Vos 2014-11-11 03:24:30 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users

Note You need to log in before you can comment on or make changes to this bug.