Bug 1028282 - Create Volume: No systems root partition error when script mode
Create Volume: No systems root partition error when script mode
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Krutika Dhananjay
SATHEESARAN
: ZStream
Depends On: 1028281
Blocks: 1008942
  Show dependency treegraph
 
Reported: 2013-11-08 00:40 EST by Aravinda VK
Modified: 2015-05-13 12:31 EDT (History)
13 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.47.1u2rhs
Doc Type: Bug Fix
Doc Text:
Previously by design, creation of bricks on root partition was made to succeed in script mode, during volume creation. With this update, this operation is not allowed and volume creation fails with an error message when bricks are being created in root partition, even in script mode.
Story Points: ---
Clone Of: 1028281
Environment:
Last Closed: 2014-02-25 03:01:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2013-11-08 00:40:38 EST
+++ This bug was initially created as a clone of Bug #1028281 +++

Description of problem:
When we try to create volume with bricks in root partition, gluster cli will give following error. But it creates volume successfully in script mode.

gluster volume create gv1 sumne.sumne:/gfs/gv1_b1 sumne.sumne:/gfs/gv1_b2

volume create: gv1: failed: The brick sumne.sumne:/gfs/gv1_b1 is is being created in the root partition. It is recommended that you don't use the system's root partition for storage backend. Or use 'force' at the end of the command if you want to override this behavior.


How reproducible:
100%

Steps to Reproduce:
1. Create volume with bricks dir in root partition
gluster volume create gv1 sumne.sumne:/gfs/gv1_b1 sumne.sumne:/gfs/gv1_b2
It will fail with above mentioned error
2. Create volume with script mode
gluster volume create gv1 sumne.sumne:/gfs/gv1_b1 sumne.sumne:/gfs/gv1_b2 --mode=script
Creates volume successfully.

Actual results:
Creates volume successfully without any error.

Expected results:
Script mode should fail if brick dirs are system's root partition.
Comment 2 Amar Tumballi 2013-11-26 01:50:16 EST
The idea here was 'force' is inbuilt into the command in script mode. Isn't that expected?
Comment 3 Aravinda VK 2013-11-26 02:09:07 EST
script mode bypasses all warnings and Yes/No kind of prompts. For example "Y" in volume stop.

But in this case CLI is throwing error and script mode is succeeding, Problem with this is from UI(ovirt) we can't prevent users from creating bricks in system's root partition.
Comment 5 SATHEESARAN 2013-12-19 10:14:47 EST
Verified with glusterfs-3.4.0.51rhs.el6rhs with the following steps:

case-1 - without --mode=script
==============================
[root@rhss1 ~]# gluster volume create test 10.70.37.86:/rhs/brick3
volume create: test: failed: The brick 10.70.37.86:/rhs/brick3 is a mount point. Please create a sub-directory under the mount point and use that as the brick directory. Or use 'force' at the end of the command if you want to override this behavior.


case-2 - with --mode=script
===========================
[root@rhss1 ~]# gluster volume create test 10.70.37.86:/rhs/brick3 --mode=script
volume create: test: failed: The brick 10.70.37.86:/rhs/brick3 is a mount point. Please create a sub-directory under the mount point and use that as the brick directory. Or use 'force' at the end of the command if you want to override this behavior.
Comment 6 Pavithra 2014-01-07 02:03:30 EST
Can you please review the doc text for technical accuracy?
Comment 7 Krutika Dhananjay 2014-01-07 02:16:51 EST
LGTM.
Comment 9 errata-xmlrpc 2014-02-25 03:01:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.