Bug 1028332 - fails during `repoquery -l filesystem`-stage
fails during `repoquery -l filesystem`-stage
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
: 1039289 (view as bug list)
Depends On: 1028352
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 03:49 EST by Björn 'besser82' Esser
Modified: 2014-01-07 04:41 EST (History)
8 users (show)

See Also:
Fixed In Version: fedora-review-0.5.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:06:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Björn 'besser82' Esser 2013-11-08 03:49:21 EST
Description of problem:

  Running `fedora-review -m fedora-rawhide-$arch -b $rhbz` fails, because the
  stage invoking repoquery uses the wrong $RELEASEVER.  rawhide != F20


Version-Release number of selected component (if applicable):

  0.5.0-3.fc20.noarch


How reproducible:

  100%


Steps to Reproduce:

  1. invoke `fedora-review -m fedora-rawhide-$arch -b $rhbz`
  2. wait a bit
  3. BANG!


Actual results:

  fails when invoking `repoquery -l filesystem`:

  <snip!>
  http://ftp.lip6.fr/ftp/pub/linux/distributions/fedora/development/20/x86_64/os/repodata/6475e242d6b3ea685a85ad139f6a022c15422622725d5271d600d5b68ef8d545-filelists.sqlite.bz2: [Errno 14] HTTP Error 404 - Not Found
  WARNING: Cannot run yum makecache, trouble ahead
  INFO: Active plugins: Generic, Python, Shell-api
  Caching enabled and local cache: /var/tmp/yum-besser82-EZGKPu/x86_64/20/fedora/6475e242d6b3ea685a85ad139f6a022c15422622725d5271d600d5b68ef8d545-filelists.sqlite.bz2 does not match checksum
  ERROR: Exception down the road...

  ---> file is not found, because it is located (with matching checksum) in
       .../fedora/development/rawhide/...


Expected results:

  run should finish as expected
Comment 1 Björn 'besser82' Esser 2013-11-08 04:38:36 EST
Additional info:

  mock-1.1.33-1.fc20.noarch works fine.  No issues with that version.  :)

  If you are affected by this do `yum downgrade mock` and everything is
  fine again.
Comment 2 Alec Leamas 2013-11-08 05:37:33 EST
temporary fix in devel: http://git.fedorahosted.org/cgit/FedoraReview.git/commit/?id=234ad67
Comment 3 Alec Leamas 2013-11-08 07:35:44 EST
This might or might not be related  to the default.cfg being stale after update:

$ ls -l /etc/mock/default.cfg
lrwxrwxrwx 1 root root 18 31 okt 13.07 /etc/mock/default.cfg -> fedora--x86_64.cf
Comment 4 Michele Baldessari 2013-11-16 15:43:47 EST
The change at c#2 fixed it for me. Thanks Alec
Comment 5 Timothy St. Clair 2013-12-03 11:21:55 EST
I also hit this.
Comment 6 Fedora Update System 2013-12-13 09:59:25 EST
fedora-review-0.5.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-1.fc18
Comment 7 Fedora Update System 2013-12-13 10:00:05 EST
fedora-review-0.5.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-1.el6
Comment 8 Fedora Update System 2013-12-13 10:01:26 EST
fedora-review-0.5.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-1.fc19
Comment 9 Fedora Update System 2013-12-13 12:55:56 EST
Package fedora-review-0.5.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-review-0.5.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23340/fedora-review-0.5.1-1.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-12-19 02:06:02 EST
fedora-review-0.5.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Stanislav Ochotnicky 2013-12-19 03:44:53 EST
*** Bug 1039289 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2014-01-06 20:20:42 EST
fedora-review-0.5.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2014-01-07 04:36:04 EST
fedora-review-0.5.1-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2014-01-07 04:41:00 EST
fedora-review-0.5.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.