Bug 1028334 - Yum traceback when spawnl(applydeltarpm) hits resource limits
Yum traceback when spawnl(applydeltarpm) hits resource limits
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdeněk Pavlas
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:edf9f0a06529e51cf510b81415d...
:
: 1029281 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 03:53 EST by Satyendra Singh
Modified: 2014-02-02 17:29 EST (History)
7 users (show)

See Also:
Fixed In Version: yum-3.4.3-120.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-10 01:12:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.11 KB, text/plain)
2013-11-08 03:53 EST, Satyendra Singh
no flags Details
File: dso_list (70 bytes, text/plain)
2013-11-08 03:54 EST, Satyendra Singh
no flags Details
File: environ (2.93 KB, text/plain)
2013-11-08 03:54 EST, Satyendra Singh
no flags Details

  None (edit)
Description Satyendra Singh 2013-11-08 03:53:40 EST
Description of problem:
i don't know

Version-Release number of selected component:
yum-3.4.3-106.fc20

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/yum update -y
executable:     /usr/bin/yum
kernel:         3.11.6-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
os.py:531:_spawnvef:OSError: [Errno 12] Cannot allocate memory

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 316, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 219, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 630, in doTransaction
    problems = self.downloadPkgs(downloadpkgs, callback_total=self.download_callback_total_cb)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2454, in downloadPkgs
    urlgrabber.grabber.parallel_wait()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2328, in parallel_wait
    perform()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2200, in perform
    try: _run_callback(opts.checkfunc, opts)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1030, in _run_callback
    return cb(obj)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2421, in checkfunc
    presto.rebuild(po)
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 269, in rebuild
    self.dequeue_max()
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 301, in dequeue_max
    if not self.dequeue(block=False):
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 322, in dequeue
    pid = os.spawnl(os.P_NOWAIT, APPLYDELTA, APPLYDELTA, *args)
  File "/usr/lib64/python2.7/os.py", line 608, in spawnl
    return spawnv(mode, file, args)
  File "/usr/lib64/python2.7/os.py", line 563, in spawnv
    return _spawnvef(mode, file, args, None, execv)
  File "/usr/lib64/python2.7/os.py", line 531, in _spawnvef
    pid = fork()
OSError: [Errno 12] Cannot allocate memory

Local variables in innermost frame:
file: '/usr/bin/applydeltarpm'
args: ('/usr/bin/applydeltarpm', '-a', 'x86_64', '/var/cache/yum/x86_64/20/updates-testing/packages/kernel-3.11.6-300.fc20_3.11.6-301.fc20.x86_64.drpm', '/var/cache/yum/x86_64/20/updates-testing/packages/kernel-3.11.6-301.fc20.x86_64.rpm')
env: None
func: <built-in function execv>
mode: 1
Comment 1 Satyendra Singh 2013-11-08 03:53:54 EST
Created attachment 821454 [details]
File: backtrace
Comment 2 Satyendra Singh 2013-11-08 03:54:00 EST
Created attachment 821455 [details]
File: dso_list
Comment 3 Satyendra Singh 2013-11-08 03:54:05 EST
Created attachment 821456 [details]
File: environ
Comment 4 Zdeněk Pavlas 2013-11-12 03:14:11 EST
*** Bug 1029281 has been marked as a duplicate of this bug. ***
Comment 5 Leighton Brown 2013-11-15 04:42:01 EST
Hi,

I believe I had a virtual box session open when the issue occurred. After closing the virtual box session I was able to run yum.
Comment 6 Fedora Update System 2013-12-04 11:32:42 EST
yum-3.4.3-119.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yum-3.4.3-119.fc19
Comment 7 Fedora Update System 2013-12-04 11:35:08 EST
yum-3.4.3-119.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/yum-3.4.3-119.fc20
Comment 8 Fedora Update System 2013-12-04 19:39:06 EST
Package yum-3.4.3-119.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-119.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22706/yum-3.4.3-119.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-12-06 09:25:06 EST
yum-3.4.3-120.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yum-3.4.3-120.fc19
Comment 10 Fedora Update System 2013-12-06 09:33:23 EST
yum-3.4.3-120.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/yum-3.4.3-120.fc20
Comment 11 Fedora Update System 2013-12-10 01:12:23 EST
yum-3.4.3-120.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-12-13 22:30:53 EST
yum-3.4.3-120.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.