Bug 1029281 - [abrt] yum-3.4.3-106.fc19: os.py:531:_spawnvef:OSError: [Errno 12] Cannot allocate memory
[abrt] yum-3.4.3-106.fc19: os.py:531:_spawnvef:OSError: [Errno 12] Cannot all...
Status: CLOSED DUPLICATE of bug 1028334
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:edf9f0a06529e51cf510b81415d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 23:31 EST by Leighton Brown
Modified: 2013-11-12 03:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 03:14:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.08 KB, text/plain)
2013-11-11 23:31 EST, Leighton Brown
no flags Details
File: cmdline (77 bytes, text/plain)
2013-11-11 23:31 EST, Leighton Brown
no flags Details
File: dso_list (70 bytes, text/plain)
2013-11-11 23:31 EST, Leighton Brown
no flags Details
File: environ (2.32 KB, text/plain)
2013-11-11 23:31 EST, Leighton Brown
no flags Details

  None (edit)
Description Leighton Brown 2013-11-11 23:31:29 EST
Description of problem:
while trying to install the updates of November 11 on my system. During the download phase. While downloading libreoffice-pyuno-4.1.3.2-4.fc19.x86_64.rpm:
Traceback (most recent call last):c19.noa 49% [===============-                ] 1.2 MB/s | 131 MB  00:01:54 ETA
  File "/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 355, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 261, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 667, in doTransaction
    problems = self.downloadPkgs(downloadpkgs, callback_total=self.download_callback_total_cb)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2469, in downloadPkgs
    urlgrabber.grabber.parallel_wait()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2275, in parallel_wait
    perform()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2200, in perform
    try: _run_callback(opts.checkfunc, opts)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1030, in _run_callback
    return cb(obj)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2439, in checkfunc
    presto.dequeue_max()
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 316, in dequeue_max
    if not self.dequeue(block=False):
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 337, in dequeue
    pid = os.spawnl(os.P_NOWAIT, APPLYDELTA, APPLYDELTA, *args)
  File "/usr/lib64/python2.7/os.py", line 608, in spawnl
    return spawnv(mode, file, args)
  File "/usr/lib64/python2.7/os.py", line 563, in spawnv
    return _spawnvef(mode, file, args, None, execv)
  File "/usr/lib64/python2.7/os.py", line 531, in _spawnvef
    pid = fork()
OSError: [Errno 12] Cannot allocate memory

Version-Release number of selected component:
yum-3.4.3-106.fc19

Additional info:
reporter:       libreport-2.1.8
executable:     /usr/bin/yum
kernel:         3.11.1-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
os.py:531:_spawnvef:OSError: [Errno 12] Cannot allocate memory

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 316, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 219, in main
    return_code = base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 630, in doTransaction
    problems = self.downloadPkgs(downloadpkgs, callback_total=self.download_callback_total_cb)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2454, in downloadPkgs
    urlgrabber.grabber.parallel_wait()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2242, in parallel_wait
    perform()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2172, in perform
    try: _run_callback(opts.checkfunc, opts)
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 1010, in _run_callback
    return cb(obj)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2421, in checkfunc
    presto.rebuild(po)
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 269, in rebuild
    self.dequeue_max()
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 301, in dequeue_max
    if not self.dequeue(block=False):
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 322, in dequeue
    pid = os.spawnl(os.P_NOWAIT, APPLYDELTA, APPLYDELTA, *args)
  File "/usr/lib64/python2.7/os.py", line 608, in spawnl
    return spawnv(mode, file, args)
  File "/usr/lib64/python2.7/os.py", line 563, in spawnv
    return _spawnvef(mode, file, args, None, execv)
  File "/usr/lib64/python2.7/os.py", line 531, in _spawnvef
    pid = fork()
OSError: [Errno 12] Cannot allocate memory

Local variables in innermost frame:
file: '/usr/bin/applydeltarpm'
args: ('/usr/bin/applydeltarpm', '-a', 'x86_64', '/var/cache/yum/x86_64/19/updates/packages/gssdp-0.14.4-1.fc19_0.14.5-1.fc19.x86_64.drpm', '/var/cache/yum/x86_64/19/updates/packages/gssdp-0.14.5-1.fc19.x86_64.rpm')
env: None
func: <built-in function execv>
mode: 1

Potential duplicate: bug 1028334
Comment 1 Leighton Brown 2013-11-11 23:31:34 EST
Created attachment 822756 [details]
File: backtrace
Comment 2 Leighton Brown 2013-11-11 23:31:37 EST
Created attachment 822757 [details]
File: cmdline
Comment 3 Leighton Brown 2013-11-11 23:31:41 EST
Created attachment 822758 [details]
File: dso_list
Comment 4 Leighton Brown 2013-11-11 23:31:44 EST
Created attachment 822759 [details]
File: environ
Comment 5 Zdeněk Pavlas 2013-11-12 03:14:11 EST

*** This bug has been marked as a duplicate of bug 1028334 ***

Note You need to log in before you can comment on or make changes to this bug.