Bug 1028747 - Unable to turn on iwl3945: Error sending C_RXON: enqueue_hcmd failed: -5
Unable to turn on iwl3945: Error sending C_RXON: enqueue_hcmd failed: -5
Status: CLOSED DUPLICATE of bug 732029
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 06:44 EST by Deweloper
Modified: 2013-11-10 09:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 09:48:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deweloper 2013-11-10 06:44:12 EST
Description of problem:
Unable to turn on Wi-Fi on HP nx7400 EY508ES by pressing the kill switch. LED indicator is off all the time. NetworkManager says that Wi-Fi network is turned off by a hardware kill switch.
I get following messages in dmesg:

[ 4255.071832] IPv6: ADDRCONF(NETDEV_UP): wlp16s0: link is not ready
[ 4273.048292] iwl3945 0000:10:00.0: Card state received: HW:Kill SW:On
[ 4273.062070] iwl3945 0000:10:00.0: Not sending command - RF KILL
[ 4273.062083] iwl3945 0000:10:00.0: Error sending C_RXON: enqueue_hcmd failed: -5
[ 4273.062093] iwl3945 0000:10:00.0: Error setting new configuration (-5).
[ 4273.063027] iwl3945 0000:10:00.0: Master Disable Timed Out, 100 usec

Log from boot + single pressing the RF kill switch (grep iwl):

[   11.020977] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:ds
[   11.020982] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[   11.021192] iwl3945 0000:10:00.0: can't disable ASPM; OS doesn't have ASPM control
[   11.074897] iwl3945 0000:10:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[   11.074903] iwl3945 0000:10:00.0: Detected Intel Wireless WiFi Link 3945ABG
[   11.074980] iwl3945 0000:10:00.0: irq 44 for MSI/MSI-X
[   11.118648] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[   31.718068] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
[   31.796885] iwl3945 0000:10:00.0: Card state received: HW:Kill SW:On
[   31.807041] iwl3945 0000:10:00.0: Not sending command - RF KILL
[   31.807049] iwl3945 0000:10:00.0: Error sending C_RXON: enqueue_hcmd failed: -5
[   31.807054] iwl3945 0000:10:00.0: Error setting new configuration (-5).
[   31.808009] iwl3945 0000:10:00.0: Master Disable Timed Out, 100 usec

Version-Release number of selected component (if applicable):
Fedora 19 XFCE (Live UUID: 745962d7-fff7-4fff-9251-8207cd1aadae)
kernel-3.11.7-200.fc19.i686
3.11.7-200.fc19.i686 #1 SMP Mon Nov 4 14:32:57 UTC 2013 i686 i686 i386 GNU/Linux

How reproducible:
100%

Steps to Reproduce:
1. Reboot laptop with RF off
2. Try to turn RF on

Actual results:
No WiFi, LED next to RF kill switch off.

Expected results:
WiFi working, blue LED indicator on.
Comment 1 Deweloper 2013-11-10 09:48:39 EST

*** This bug has been marked as a duplicate of bug 732029 ***

Note You need to log in before you can comment on or make changes to this bug.