Bug 102879 - librt.so.1 in /usr/lib
Summary: librt.so.1 in /usr/lib
Status: CLOSED DUPLICATE of bug 102853
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-22 09:05 UTC by Alexander Larsson
Modified: 2016-11-24 14:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander Larsson 2003-08-22 09:05:40 UTC
There was a change in glibc somewhere between 2.3.2-57 and 2.3.2-66 that
adds /usr/lib/librt.so.1 to glibc-devel. The file is just a symlink to
librt.so. This change seems wrong to me, and its causing breakage with
TLS.

I have an app not linking to librt, but it dlopens a library that links
to librt.so.1. The app gets the tls libc at /lib/tls/libc.so.6, but when
resolving the librt.so.1 DT_NEEDED it first looks in the system library,
finding /usr/lib/librt.so.1. However, following this symlink gets you
/lib/librt.so.1 which is the non-TLS version of librt. This means we
have mismatched librt and libc versions, causing:

/usr/lib/librt.so.1: symbol __librt_disable_asynccancel, version
GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

Having the soname librt in /usr/lib just seems wrong to me. What was the
reason for introducing it?

Comment 1 Nils Philippsen 2003-08-22 09:50:57 UTC

*** This bug has been marked as a duplicate of 102853 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.