Bug 102853 - /usr/bin/gtk-query-immodules-2.0 fails in %post script
/usr/bin/gtk-query-immodules-2.0 fails in %post script
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: glibc (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
: 102879 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-08-21 16:53 EDT by Nils Philippsen
Modified: 2016-11-24 07:25 EST (History)
6 users (show)

See Also:
Fixed In Version: 2.3.2-78
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-27 09:55:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2003-08-21 16:53:13 EDT
Description of problem:

The %post script contains this command:

/usr/bin/gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules

which gives this error message:

Cannot load module /usr/lib/gtk-2.0/2.2.0/immodules/im-gucharmap.so:
/usr/lib/librt.so.1: symbol __librt_disable_asynccancel, version GLIBC_PRIVATE
not defined in file libc.so.6 with link time reference
/usr/lib/gtk-2.0/2.2.0/immodules/im-gucharmap.so does not export GTK+ IM module
API: /usr/lib/librt.so.1: symbol __librt_disable_asynccancel, version
GLIBC_PRIVATE not defined in file libc.so.6 with link time reference

Version-Release number of selected component (if applicable):

gnome-utils-2.3.4-1

How reproducible:

Easy

Steps to Reproduce:
1. Install package

Actual results:

Error message

Expected results:

No error message, info about module written to /etc/gtk-2.0/gtk.immodules

Additional info:

glibc-2.3.2-71
gtk2-2.2.2-2.1
Comment 1 Ulrich Drepper 2003-08-22 04:13:46 EDT
You are mixing the TLS libc with the non-TLS librt.  Does the code load
"/lib/librt.so.1" directly or somthing like that?  This is wrong.  If the TLS
libc is used the TLS librt in /lib/tls/librt.so.1 must be used as well.
Comment 2 Nils Philippsen 2003-08-22 05:50:59 EDT
*** Bug 102879 has been marked as a duplicate of this bug. ***
Comment 3 Barry K. Nathan 2003-08-23 18:49:45 EDT
(copy and paste from an e-mail I'm about to send to rhl-devel-list)

On Thu, Aug 21, 2003 at 12:07:07PM +0200, Alexander Larsson wrote:
> There was a change in glibc somewhere between 2.3.2-57 and 2.3.2-66 that
> adds /usr/lib/librt.so.1 to glibc-devel. The file is just a symlink to
> librt.so. This change seems wrong to me, and its causing breakage with
> TLS.
[snip]
> Having the soname librt in /usr/lib just seems wrong to me. What was the
> reason for introducing it?

Another question: Was the link introduced intentionally?

I've noticed that if I rm the link, it's recreated the next time I run
/sbin/ldconfig.

-Barry K. Nathan <barryn@pobox.com>

Note You need to log in before you can comment on or make changes to this bug.