Bug 1028975 - [RHS-C] Error while executing action: Cannot add Gluster Hook. The server ${VdsName} is not UP.
[RHS-C] Error while executing action: Cannot add Gluster Hook. The server ${V...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
low Severity medium
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Sahina Bose
SATHEESARAN
: ZStream
Depends On: 977355
Blocks: 1220833
  Show dependency treegraph
 
Reported: 2013-11-11 06:58 EST by Prasanth
Modified: 2017-02-11 20:35 EST (History)
16 users (show)

See Also:
Fixed In Version: 3.6.0-13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 977355
: 1220833 (view as bug list)
Environment:
Last Closed: 2016-04-19 21:37:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 28841 master MERGED engine:Fixed error message Add/remove/update Gluster Hook Never

  None (edit)
Description Prasanth 2013-11-11 06:58:02 EST
+++ This bug was initially created as a clone of Bug #977355 +++

Description of problem:

Following incorrect error message is seen during resolve conflict:

---
Error while executing action: Cannot add Gluster Hook. The server ${VdsName} is not UP.
---


Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb4.el6rhs 


How reproducible: 100%


Steps to Reproduce:
1. Have a 2 node cluster
2. Manually create a hook in node1 so that a missing conflict is created and detected in node2.
3. Put node2 into Maintenance
4. Now click on Resolve conflicts; make sure the default option (Copy the hook to all the servers) is selected and click on OK

Actual results: The following incorrect error is seen:

---
Error while executing action: Cannot add Gluster Hook. The server ${VdsName} is not UP.
---


Expected results: The error message should be proper


Additional info: Screenshot attached

--- Additional comment from RHEL Product and Program Management on 2013-06-24 07:38:23 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Dusmant on 2013-10-21 09:23:24 EDT ---

Doc Text will be added, once bug fix required rate starts tapering...

--- Additional comment from Dusmant on 2013-10-24 00:55:49 EDT ---

Not in Corbett
Comment 1 Prasanth 2013-11-11 06:58:51 EST
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.31.beta1.el6ev
Comment 3 Eyal Edri 2015-02-25 03:45:31 EST
3.5.1 is already full with bugs (over 80), and since none of these bugs were added as urgent for 3.5.1 release in the tracker bug, moving to 3.5.2
Comment 7 SATHEESARAN 2016-01-28 02:18:10 EST
Tested with RHGS 3.1.2 nightly ( glusterfs-3.7.1-17el7rhgs ) and RHEV 3.6.2.6

While repeating the steps mentioned in comment0, the error messages is thrown as "Error while executing action: Cannot add Gluster Hook. The server RHGS-Node-2 is not UP."

Marking this bug as VERIFIED
Comment 8 SATHEESARAN 2016-01-28 03:24:14 EST
Note :
RHGS 3.1.2 has vdsm 4.16.z and it can't be added to RHEVM 3.6
So I have used the custom build vdsm & vdsm gluster of build 4.17.16 to add it to RHEV 3.6.2.6
Comment 9 Sahina Bose 2016-01-28 03:31:15 EST
You should be able to add RHGS 3.1.2 to a 3.5 cluster level in RHEV-M 3.6, and verify this.
Comment 10 SATHEESARAN 2017-02-11 20:35:11 EST
(In reply to Sahina Bose from comment #9)
> You should be able to add RHGS 3.1.2 to a 3.5 cluster level in RHEV-M 3.6,
> and verify this.

Tested and verified the same. Apologies for the late update

Note You need to log in before you can comment on or make changes to this bug.