Bug 977355 - [RHS-C] Error while executing action: Cannot add Gluster Hook. The server ${VdsName} is not UP. [NEEDINFO]
Summary: [RHS-C] Error while executing action: Cannot add Gluster Hook. The server ${V...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.1
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: RHGS 3.1.0
Assignee: Karnan
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On:
Blocks: 1028975 1035040 1202842
TreeView+ depends on / blocked
 
Reported: 2013-06-24 11:28 UTC by Prasanth
Modified: 2016-11-14 00:04 UTC (History)
13 users (show)

Fixed In Version: rhsc-3.1.0-57
Doc Type: Bug Fix
Doc Text:
Previously, when a server was down, the error message that was returned did not contain the server name. As a consequence, identifying the server that is down using this error message was not possible. With this fix, the server is easily identifiable from the error message.
Clone Of:
: 1028975 (view as bug list)
Environment:
Last Closed: 2015-07-29 05:24:47 UTC
Target Upstream Version:
divya: needinfo? (kchidamb)


Attachments (Terms of Use)
screenshot of error (40.45 KB, image/png)
2013-06-24 11:28 UTC, Prasanth
no flags Details
Screenshot for gluster hooks (197.81 KB, image/png)
2015-05-27 12:11 UTC, RamaKasturi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1494 0 normal SHIPPED_LIVE Red Hat Gluster Storage Console 3.1 Enhancement and bug fixes 2015-07-29 09:24:02 UTC
oVirt gerrit 28841 0 master MERGED engine:Fixed error message Add/remove/update Gluster Hook 2020-10-08 17:26:12 UTC
oVirt gerrit 40517 0 ovirt-engine-3.5-gluster MERGED engine:Fixed error message Add/remove/update Gluster Hook 2020-10-08 17:26:12 UTC

Description Prasanth 2013-06-24 11:28:16 UTC
Created attachment 764555 [details]
screenshot of error

Description of problem:

Following incorrect error message is seen during resolve conflict:

---
Error while executing action: Cannot add Gluster Hook. The server ${VdsName} is not UP.
---


Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb4.el6rhs 


How reproducible: 100%


Steps to Reproduce:
1. Have a 2 node cluster
2. Manually create a hook in node1 so that a missing conflict is created and detected in node2.
3. Put node2 into Maintenance
4. Now click on Resolve conflicts; make sure the default option (Copy the hook to all the servers) is selected and click on OK

Actual results: The following incorrect error is seen:

---
Error while executing action: Cannot add Gluster Hook. The server ${VdsName} is not UP.
---


Expected results: The error message should be proper


Additional info: Screenshot attached

Comment 2 Dusmant 2013-10-21 13:23:24 UTC
Doc Text will be added, once bug fix required rate starts tapering...

Comment 3 Dusmant 2013-10-24 04:55:49 UTC
Not in Corbett

Comment 4 Shalaka 2013-12-26 10:13:57 UTC
Sahina, This bug has been identified as known issue, hence, please add the DocText.

Comment 5 Shalaka 2014-01-03 09:47:37 UTC
Please review the edited DocText.

Comment 6 Sahina Bose 2014-01-20 05:54:47 UTC
Doc text looks good

Comment 7 RamaKasturi 2015-05-27 12:10:05 UTC
Verified and works with the build rhsc-3.1.0-0.57.master.el6.noarch.

Create a hook manually in one of the node in the cluster and put the other node to  maintenance state. Now click on resolve conflicts and click "ok"

UI displays an error saying "Error while executing action: Cannot add Gluster Hook. The server <servername> is not UP". Attaching the screenshot.

Comment 8 RamaKasturi 2015-05-27 12:11:03 UTC
Created attachment 1030506 [details]
Screenshot for gluster hooks

Comment 9 Divya 2015-07-26 10:58:02 UTC
Karnan,

Could you review and sign-off the edited doc text.

Comment 11 errata-xmlrpc 2015-07-29 05:24:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1494.html


Note You need to log in before you can comment on or make changes to this bug.