Bug 1028976 - [RHSC] Remove hooks from a cluster, when all servers in the cluster are removed from engine.
[RHSC] Remove hooks from a cluster, when all servers in the cluster are remov...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.4.0
Assigned To: Sahina Bose
SATHEESARAN
gluster
:
Depends On: 986171
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 07:03 EST by Prasanth
Modified: 2016-02-10 13:58 EST (History)
14 users (show)

See Also:
Fixed In Version: av3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 986171
Environment:
Last Closed: 2014-06-12 10:04:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sabose: Triaged?


Attachments (Terms of Use)

  None (edit)
Description Prasanth 2013-11-11 07:03:24 EST
+++ This bug was initially created as a clone of Bug #986171 +++

Description of problem:
-----------------------------
When all the servers in a cluster are removed, the gluster hooks tab for the cluster still displays the hooks that were present. When the 'Sync' button is clicked, it fails to sync hooks as the cluster does not have any UP servers.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb6.el6rhs 

How reproducible:
Always

Steps to Reproduce:
1. Create a 3.2 cluster via the Console.
2. Add a server and sync the hooks.
3. Remove the server.

Actual results:
Hooks still being displayed in the Gluster Hooks tab for the cluster.

Expected results:
When the last server is removed from the cluster, the engine should no longer have the hooks that were present in the cluster, and the Console should not display the hooks that were present.

Additional info:
Attaching engine logs.

--- Additional comment from RHEL Product and Program Management on 2013-07-19 02:42:37 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Scott Haines on 2013-09-23 19:34:58 EDT ---

Targeting for 2.1.z U2 (Corbett) release.
Comment 1 Prasanth 2013-11-11 07:04:08 EST
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.31.beta1.el6ev
Comment 2 Sahina Bose 2013-12-19 04:22:28 EST
This is available upstream, so should be fixed in 3.4. To move to ON_QA when 3.4 builds are available
Comment 3 Prasanth 2013-12-19 06:51:46 EST
Assigning it to Satheesaran (sasundar@redhat.com) as he is the QA contact for  RHEV-RHS
Comment 4 SATHEESARAN 2014-05-15 14:52:47 EDT
Verified this bug with RHEVM 3.4 [av9.1]

1. Added 4 RHS 3.0 ( glusterfs-3.6.0.1-1.el6rhs ) nodes to gluster enabled cluster
2. Clicked on cluster, and moved to "gluster hooks" tab and I could see all the hooks shown up
3. Removed all the RHS nodes from the cluster
4. Contents under the hooks tab was empty

marking this bug as VERIFIED
Comment 5 Itamar Heim 2014-06-12 10:04:29 EDT
Closing as part of 3.4.0

Note You need to log in before you can comment on or make changes to this bug.