Bug 986171 - [RHSC] Remove hooks from a cluster, when all servers in the cluster are removed from engine.
[RHSC] Remove hooks from a cluster, when all servers in the cluster are remov...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Sahina Bose
Shruti Sampat
: ZStream
Depends On:
Blocks: 1028976
  Show dependency treegraph
 
Reported: 2013-07-19 02:27 EDT by Shruti Sampat
Modified: 2015-05-13 12:27 EDT (History)
10 users (show)

See Also:
Fixed In Version: cb10
Doc Type: Bug Fix
Doc Text:
Previously, the list of hooks from the removed hosts were displayed in the Gluster Hooks tab. Now, with this update, the hook list is cleared when the hosts are removed from the cluster.
Story Points: ---
Clone Of:
: 1028976 (view as bug list)
Environment:
Last Closed: 2014-02-25 02:33:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (22.49 KB, text/x-log)
2013-07-19 02:27 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21529 None None None Never

  None (edit)
Description Shruti Sampat 2013-07-19 02:27:24 EDT
Created attachment 775648 [details]
engine logs

Description of problem:
-----------------------------
When all the servers in a cluster are removed, the gluster hooks tab for the cluster still displays the hooks that were present. When the 'Sync' button is clicked, it fails to sync hooks as the cluster does not have any UP servers.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb6.el6rhs 

How reproducible:
Always

Steps to Reproduce:
1. Create a 3.2 cluster via the Console.
2. Add a server and sync the hooks.
3. Remove the server.

Actual results:
Hooks still being displayed in the Gluster Hooks tab for the cluster.

Expected results:
When the last server is removed from the cluster, the engine should no longer have the hooks that were present in the cluster, and the Console should not display the hooks that were present.

Additional info:
Attaching engine logs.
Comment 2 Scott Haines 2013-09-23 19:34:58 EDT
Targeting for 2.1.z U2 (Corbett) release.
Comment 3 Matt Mahoney 2013-12-02 15:20:25 EST
Verified in cb10, against 3.2 and 3.3 clusters.
Comment 4 Shalaka 2014-01-07 05:14:29 EST
Please review the edited DocText and signoff.
Comment 5 Sahina Bose 2014-01-30 02:11:56 EST
Doctext ok
Comment 7 errata-xmlrpc 2014-02-25 02:33:22 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.