Bug 1029461 - Default unmount is in 10 seconds, man page says 10 minutes
Default unmount is in 10 seconds, man page says 10 minutes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 1030705
  Show dependency treegraph
 
Reported: 2013-11-12 07:35 EST by Kamil Páral
Modified: 2013-12-13 22:54 EST (History)
1 user (show)

See Also:
Fixed In Version: autofs-5.0.7-35.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1030705 (view as bug list)
Environment:
Last Closed: 2013-12-13 22:54:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
auto.master (753 bytes, text/plain)
2013-11-13 07:18 EST, Kamil Páral
no flags Details
auto.auto (180 bytes, text/plain)
2013-11-13 07:18 EST, Kamil Páral
no flags Details
autofs (3.80 KB, text/plain)
2013-11-13 07:20 EST, Kamil Páral
no flags Details
Patch - improve timeout option description (3.03 KB, patch)
2013-11-14 20:47 EST, Ian Kent
no flags Details | Diff

  None (edit)
Description Kamil Páral 2013-11-12 07:35:31 EST
Description of problem:
Man automount says:
       -t, --timeout
              Set the global minimum timeout, in seconds, until directories are unmounted. The default is 10 minutes. Setting the timeout to zero disables umounts completely.

However, the default timeout is 10 seconds. The daemon says:

$ sudo automount -v -f
Starting automounter version 5.0.7-29.fc20, master map auto.master
using kernel protocol version 5.02
mounted indirect on /mnt/auto with timeout 10, freq 3 seconds

And in 10 seconds, my NFS directories are unmounted.

The man page should be corrected, or the software should be corrected.

Version-Release number of selected component (if applicable):
autofs-5.0.7-29.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. run the daemon in default configuration
2. see that NFS shares are unmounted in 10 seconds
Comment 1 Ian Kent 2013-11-12 20:23:34 EST
(In reply to Kamil Páral from comment #0)
> Description of problem:
> Man automount says:
>        -t, --timeout
>               Set the global minimum timeout, in seconds, until directories
> are unmounted. The default is 10 minutes. Setting the timeout to zero
> disables umounts completely.

The Fedora installed configuration changes that to 5 minutes.

> 
> However, the default timeout is 10 seconds. The daemon says:
> 
> $ sudo automount -v -f
> Starting automounter version 5.0.7-29.fc20, master map auto.master
> using kernel protocol version 5.02
> mounted indirect on /mnt/auto with timeout 10, freq 3 seconds
> 
> And in 10 seconds, my NFS directories are unmounted.
> 
> The man page should be corrected, or the software should be corrected.

You should have a look at the configuration and post it
as evidence that something isn't working correctly.

> 
> Version-Release number of selected component (if applicable):
> autofs-5.0.7-29.fc20.x86_64
> 
> How reproducible:
> always

Works fine for me.

> 
> Steps to Reproduce:
> 1. run the daemon in default configuration
> 2. see that NFS shares are unmounted in 10 seconds

I can't reproduce this behaviour.

It's possible there's a bug in f20 so post the autofs
configuration that is being used and if you really have
observed a problem I'll look into it.
Comment 2 Ian Kent 2013-11-12 20:25:01 EST
You haven't posted the autofs configuration either, you should
also do that.
Comment 3 Kamil Páral 2013-11-13 07:18:02 EST
Created attachment 823385 [details]
auto.master
Comment 4 Kamil Páral 2013-11-13 07:18:06 EST
Created attachment 823386 [details]
auto.auto
Comment 5 Kamil Páral 2013-11-13 07:20:19 EST
Created attachment 823387 [details]
autofs
Comment 6 Kamil Páral 2013-11-13 07:27:37 EST
You are right, my /etc/sysconfig/autofs configuration was changed (probably long time ago) to 10 seconds. Sorry about the false alarm.

However, this indicates there are 2 areas to improve:

1. The man page does not reflect Fedora-specific patches.

2. No man page speaks about /etc/sysconfig/autofs (man autofs, man automount, etc). That is the reason I did not find the changed TIMEOUT value. I was looking into manpages and then looking into /etc/auto* files. Only after your comment I performed "rpm -qc autofs" and found /etc/sysconfig/autofs. If would be good to include this file name into the man page, so that other people are not fooled similarly as I was, believing that /etc/auto* is the only configuration present. Thanks for consideration.
Comment 7 Kamil Páral 2013-11-13 07:28:14 EST
Oh, please free to close this as notabug if you decide not to adjust the man pages or track the issue elsewhere. Thanks.
Comment 8 Ian Kent 2013-11-13 19:24:16 EST
(In reply to Kamil Páral from comment #6)
> You are right, my /etc/sysconfig/autofs configuration was changed (probably
> long time ago) to 10 seconds. Sorry about the false alarm.
> 
> However, this indicates there are 2 areas to improve:
> 
> 1. The man page does not reflect Fedora-specific patches.

There is no Fedora specific configuration.
It's possible that a current configuration hasn't been
installed due to the existence of an old one, since we
don't overwrite existing configurations.

The installed configuration has has this above the TIMEOUT
configuration entry for a long time now.

# TIMEOUT - set the default mount timeout in secons. The internal
#           program default is 10 minutes, but the default installed
#           configuration overrides this and sets the timeout to 5
#           minutes to be consistent with earlier autofs releases.

> 
> 2. No man page speaks about /etc/sysconfig/autofs (man autofs, man
> automount, etc). That is the reason I did not find the changed TIMEOUT
> value. I was looking into manpages and then looking into /etc/auto* files.
> Only after your comment I performed "rpm -qc autofs" and found
> /etc/sysconfig/autofs. If would be good to include this file name into the
> man page, so that other people are not fooled similarly as I was, believing
> that /etc/auto* is the only configuration present. Thanks for consideration.

auto.master(5) talks quite a bit about configuration and
mentions the path of the file within the first couple of
paragraphs. The path in sed substituted at build time so
it should be accurate.

Ian
Comment 9 Ian Kent 2013-11-13 19:26:18 EST
(In reply to Kamil Páral from comment #7)
> Oh, please free to close this as notabug if you decide not to adjust the man
> pages or track the issue elsewhere. Thanks.

You can always post patches here or upstream if you'd like
something changed but in the meantime I'll close this as
NOTABUG.
Comment 10 Kamil Páral 2013-11-14 09:56:56 EST
(In reply to Ian Kent from comment #8)
> > 1. The man page does not reflect Fedora-specific patches.
> 
> There is no Fedora specific configuration.

Let me rephrase it. This is the _default_ autofs config file (I downloaded a fresh RPM, extracted it and looked into it):

> #
> # TIMEOUT - set the default mount timeout (default 600).
> #
> TIMEOUT=300

As you can see, the default TIMEOUT in Fedora is 5 minutes. However, both the comment in the config file and the man page say 10 minutes. So I believe that should be fixed. The man page should say 5 minutes, and the autofs config file should say "(default 300)".

Just a cosmetic error, indeed.
Comment 11 Ian Kent 2013-11-14 20:31:39 EST
(In reply to Kamil Páral from comment #10)
> (In reply to Ian Kent from comment #8)
> > > 1. The man page does not reflect Fedora-specific patches.
> > 
> > There is no Fedora specific configuration.
> 
> Let me rephrase it. This is the _default_ autofs config file (I downloaded a
> fresh RPM, extracted it and looked into it):
> 
> > #
> > # TIMEOUT - set the default mount timeout (default 600).
> > #
> > TIMEOUT=300
> 
> As you can see, the default TIMEOUT in Fedora is 5 minutes. However, both
> the comment in the config file and the man page say 10 minutes. So I believe
> that should be fixed. The man page should say 5 minutes, and the autofs
> config file should say "(default 300)".
> 

Oh, I must have missed applying a patch to the upstream
source at some point. It's not like that in RHEL-6.

I'll locate the missing patch and apply it, thanks.
Comment 12 Ian Kent 2013-11-14 20:47:44 EST
Created attachment 824230 [details]
Patch - improve timeout option description

OK, it's already included in 5.0.8 and hence Rawhide,
and in RHEL-6, but it's not in RHEL-7.
Comment 13 Fedora Update System 2013-11-14 21:57:24 EST
autofs-5.0.7-30.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/autofs-5.0.7-30.fc20
Comment 14 Fedora Update System 2013-11-16 01:57:04 EST
Package autofs-5.0.7-30.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autofs-5.0.7-30.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21445/autofs-5.0.7-30.fc20
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-11-18 23:15:52 EST
autofs-5.0.7-35.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/autofs-5.0.7-35.fc20
Comment 16 Fedora Update System 2013-12-13 22:54:55 EST
autofs-5.0.7-35.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.