Bug 1030705 - Default unmount is in 10 seconds, man page says 10 minutes
Default unmount is in 10 seconds, man page says 10 minutes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: autofs (Show other bugs)
7.0
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Ian Kent
Yin.JianHong
: Reopened
Depends On: 1029461
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 20:33 EST by Ian Kent
Modified: 2014-06-18 01:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: autofs-5.0.7-35
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1029461
Environment:
Last Closed: 2014-06-13 05:18:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch - improve timeout option description (3.01 KB, patch)
2013-11-18 22:14 EST, Ian Kent
no flags Details | Diff

  None (edit)
Description Ian Kent 2013-11-14 20:33:09 EST
+++ This bug was initially created as a clone of Bug #1029461 +++

Description of problem:
Man automount says:
       -t, --timeout
              Set the global minimum timeout, in seconds, until directories are unmounted. The default is 10 minutes. Setting the timeout to zero disables umounts completely.

However, the default timeout is 10 seconds. The daemon says:

$ sudo automount -v -f
Starting automounter version 5.0.7-29.fc20, master map auto.master
using kernel protocol version 5.02
mounted indirect on /mnt/auto with timeout 10, freq 3 seconds

And in 10 seconds, my NFS directories are unmounted.

The man page should be corrected, or the software should be corrected.

Version-Release number of selected component (if applicable):
autofs-5.0.7-29.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. run the daemon in default configuration
2. see that NFS shares are unmounted in 10 seconds

--- Additional comment from Ian Kent on 2013-11-12 20:23:34 EST ---

(In reply to Kamil Páral from comment #0)
> Description of problem:
> Man automount says:
>        -t, --timeout
>               Set the global minimum timeout, in seconds, until directories
> are unmounted. The default is 10 minutes. Setting the timeout to zero
> disables umounts completely.

The Fedora installed configuration changes that to 5 minutes.

> 
> However, the default timeout is 10 seconds. The daemon says:
> 
> $ sudo automount -v -f
> Starting automounter version 5.0.7-29.fc20, master map auto.master
> using kernel protocol version 5.02
> mounted indirect on /mnt/auto with timeout 10, freq 3 seconds
> 
> And in 10 seconds, my NFS directories are unmounted.
> 
> The man page should be corrected, or the software should be corrected.

You should have a look at the configuration and post it
as evidence that something isn't working correctly.

> 
> Version-Release number of selected component (if applicable):
> autofs-5.0.7-29.fc20.x86_64
> 
> How reproducible:
> always

Works fine for me.

> 
> Steps to Reproduce:
> 1. run the daemon in default configuration
> 2. see that NFS shares are unmounted in 10 seconds

I can't reproduce this behaviour.

It's possible there's a bug in f20 so post the autofs
configuration that is being used and if you really have
observed a problem I'll look into it.

--- Additional comment from Ian Kent on 2013-11-12 20:25:01 EST ---

You haven't posted the autofs configuration either, you should
also do that.

--- Additional comment from Kamil Páral on 2013-11-13 07:18:02 EST ---



--- Additional comment from Kamil Páral on 2013-11-13 07:18:06 EST ---



--- Additional comment from Kamil Páral on 2013-11-13 07:20:19 EST ---



--- Additional comment from Kamil Páral on 2013-11-13 07:27:37 EST ---

You are right, my /etc/sysconfig/autofs configuration was changed (probably long time ago) to 10 seconds. Sorry about the false alarm.

However, this indicates there are 2 areas to improve:

1. The man page does not reflect Fedora-specific patches.

2. No man page speaks about /etc/sysconfig/autofs (man autofs, man automount, etc). That is the reason I did not find the changed TIMEOUT value. I was looking into manpages and then looking into /etc/auto* files. Only after your comment I performed "rpm -qc autofs" and found /etc/sysconfig/autofs. If would be good to include this file name into the man page, so that other people are not fooled similarly as I was, believing that /etc/auto* is the only configuration present. Thanks for consideration.

--- Additional comment from Kamil Páral on 2013-11-13 07:28:14 EST ---

Oh, please free to close this as notabug if you decide not to adjust the man pages or track the issue elsewhere. Thanks.

--- Additional comment from Ian Kent on 2013-11-13 19:24:16 EST ---

(In reply to Kamil Páral from comment #6)
> You are right, my /etc/sysconfig/autofs configuration was changed (probably
> long time ago) to 10 seconds. Sorry about the false alarm.
> 
> However, this indicates there are 2 areas to improve:
> 
> 1. The man page does not reflect Fedora-specific patches.

There is no Fedora specific configuration.
It's possible that a current configuration hasn't been
installed due to the existence of an old one, since we
don't overwrite existing configurations.

The installed configuration has has this above the TIMEOUT
configuration entry for a long time now.

# TIMEOUT - set the default mount timeout in secons. The internal
#           program default is 10 minutes, but the default installed
#           configuration overrides this and sets the timeout to 5
#           minutes to be consistent with earlier autofs releases.

> 
> 2. No man page speaks about /etc/sysconfig/autofs (man autofs, man
> automount, etc). That is the reason I did not find the changed TIMEOUT
> value. I was looking into manpages and then looking into /etc/auto* files.
> Only after your comment I performed "rpm -qc autofs" and found
> /etc/sysconfig/autofs. If would be good to include this file name into the
> man page, so that other people are not fooled similarly as I was, believing
> that /etc/auto* is the only configuration present. Thanks for consideration.

auto.master(5) talks quite a bit about configuration and
mentions the path of the file within the first couple of
paragraphs. The path in sed substituted at build time so
it should be accurate.

Ian

--- Additional comment from Ian Kent on 2013-11-13 19:26:18 EST ---

(In reply to Kamil Páral from comment #7)
> Oh, please free to close this as notabug if you decide not to adjust the man
> pages or track the issue elsewhere. Thanks.

You can always post patches here or upstream if you'd like
something changed but in the meantime I'll close this as
NOTABUG.

--- Additional comment from Kamil Páral on 2013-11-14 09:56:56 EST ---

(In reply to Ian Kent from comment #8)
> > 1. The man page does not reflect Fedora-specific patches.
> 
> There is no Fedora specific configuration.

Let me rephrase it. This is the _default_ autofs config file (I downloaded a fresh RPM, extracted it and looked into it):

> #
> # TIMEOUT - set the default mount timeout (default 600).
> #
> TIMEOUT=300

As you can see, the default TIMEOUT in Fedora is 5 minutes. However, both the comment in the config file and the man page say 10 minutes. So I believe that should be fixed. The man page should say 5 minutes, and the autofs config file should say "(default 300)".

Just a cosmetic error, indeed.

--- Additional comment from Ian Kent on 2013-11-14 20:31:39 EST ---

(In reply to Kamil Páral from comment #10)
> (In reply to Ian Kent from comment #8)
> > > 1. The man page does not reflect Fedora-specific patches.
> > 
> > There is no Fedora specific configuration.
> 
> Let me rephrase it. This is the _default_ autofs config file (I downloaded a
> fresh RPM, extracted it and looked into it):
> 
> > #
> > # TIMEOUT - set the default mount timeout (default 600).
> > #
> > TIMEOUT=300
> 
> As you can see, the default TIMEOUT in Fedora is 5 minutes. However, both
> the comment in the config file and the man page say 10 minutes. So I believe
> that should be fixed. The man page should say 5 minutes, and the autofs
> config file should say "(default 300)".
> 

Oh, I must have missed applying a patch to the upstream
source at some point. It's not like that in RHEL-6.

I'll locate the missing patch and apply it, thanks.
Comment 1 Ian Kent 2013-11-18 22:14:31 EST
Created attachment 825875 [details]
Patch - improve timeout option description
Comment 3 Yin.JianHong 2013-12-18 22:19:43 EST
verified:


[root@intel-canoepass-02 ~]# rpm -Uvh autofs-5.0.7-35.el7.x86_64.rpm 
Preparing...                          ################################# [100%]
Updating / installing...
   1:autofs-1:5.0.7-35.el7            ################################# [100%]
[root@intel-canoepass-02 ~]# rpm -q autofs
autofs-5.0.7-35.el7.x86_64


[root@intel-canoepass-02 ~]# man auto.master | cat - | grep TIMEOUT -A5 -B5
                     uration.

GENERAL SYSTEM DEFAULTS CONFIGURATION
       The default value of several general settings may be changed in the configuration file /etc/sysconfig/autofs.  They are:

       TIMEOUT
              Sets the default mount timeout in seconds. The internal program default is 10 minutes, but the default installed configuration overrides this and sets the time‐
              out to 5 minutes to be consistent with earlier autofs releases.

       NEGATIVE_TIMEOUT
              Set the default timeout for caching failed key lookups (program default 60). If the equivalent command line option is given it will override this setting.

       MOUNT_WAIT
              Set  the  default  time to wait for a response from a spawned mount(8) before sending it a SIGTERM. Note that we still need to wait for the RPC layer to timeout
              before the sub-process exits so this isn't ideal but it is the best we can do. The default is to wait until mount(8) returns without intervention.
--

       NOTE:  If a schema is given in the configuration then all the schema configuration values must be set, any partial schema specification will be ignored.

       The configuration settings available are:

       LDAP_TIMEOUT
              Set the network response timeout (default 8).  Set timeout value for the synchronous API  calls. The default is the LDAP library default of an infinite timeout.

       LDAP_NETWORK_TIMEOUT
              Set the network response timeout (default 8).

       LDAP_URI
              A space seperated list of server uris of the form <proto>://<server>[/] where <proto> can be ldap or ldaps. The option can be given multiple times.  Map entries
              that include a server name override this option and it is then not used. Default is an empty list in which case either the server given in a map  entry  or  the


[root@intel-canoepass-02 ~]# man automount | cat - | grep  -A5 -B5 -- --timeout
              Print brief help on program usage.

       -p, --pid-file
              Write the pid of the daemon to the specified file.

       -t <seconds>, --timeout <seconds>
              Set the global minimum timeout, in seconds, until directories are unmounted. The default is 10 minutes. Setting the timeout to zero disables umounts completely.
              The internal program default is 10 minutes, but the default installed configuration overrides this and sets the timeout to 5 minutes to be consistent with  ear‐
              lier autofs releases.

       -n <seconds>, --negative-timeout <seconds>
Comment 4 Ludek Smid 2014-06-13 05:18:56 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.