Bug 1029478 - [RHSC] After committing remove-brick or retaining the brick, buttons 'Commit' and 'Retain' are not disabled in the remove-brick status dialog
[RHSC] After committing remove-brick or retaining the brick, buttons 'Commit'...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Ramesh N
Shruti Sampat
: ZStream
Depends On: 1024782
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 07:57 EST by Shruti Sampat
Modified: 2015-05-13 12:34 EDT (History)
6 users (show)

See Also:
Fixed In Version: cb10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 03:03:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (1.58 MB, text/x-log)
2013-11-12 07:58 EST, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21742 None None None Never

  None (edit)
Description Shruti Sampat 2013-11-12 07:57:37 EST
Description of problem:
-----------------------
After the completion of data migration for a remove-brick operation, if the user performs Commit or Retain using the buttons in the remove-brick status dialog, after the commit or retain happens, the Commit and Retain buttons are still enabled.
Clicking on these buttons does not result in anything.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.23.master.el6_5 

How reproducible:
Always

Steps to Reproduce:
1. Start remove brick operation on a volume.
2. After the data migration has been completed, open the remove-brick status dialog and click on Commit, click OK in the confirmation dialog.

Actual results:
After the confirmation dialog for Commit disappears, it is seen that Commit and Retain buttons on the status dialog are still enabled. Clicking on either of these does not result in anything. 

If the brick was retained, the same results are observed, i.e. Commit and Retain buttons are seen to be enabled, and clicking on them results in nothing.

Expected results:
After a Commit or Retain operation, the buttons to Commit and Retain in the status dialog should be disabled.

Additional info:
Comment 1 Shruti Sampat 2013-11-12 07:58:33 EST
Created attachment 822957 [details]
engine logs
Comment 3 Shruti Sampat 2013-11-26 07:16:31 EST
Commit and Retain buttons in the status dialog not disabled after commit or retain is done from the status dialog. Moving back to ASSIGNED.
Comment 4 Ramesh N 2014-01-03 04:07:23 EST
Doc Text is not required  as its a new feature and we already have an RFE
Comment 6 errata-xmlrpc 2014-02-25 03:03:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.