Bug 1024782 - [RHSC] Retain button in the remove-brick status dialog does not work.
[RHSC] Retain button in the remove-brick status dialog does not work.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
Shruti Sampat
: ZStream
Depends On:
Blocks: 1029478
  Show dependency treegraph
 
Reported: 2013-10-30 08:29 EDT by Shruti Sampat
Modified: 2015-05-13 12:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:58:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (229.85 KB, text/x-log)
2013-10-30 08:29 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21005 None None None Never

  None (edit)
Description Shruti Sampat 2013-10-30 08:29:31 EDT
Created attachment 817449 [details]
engine logs

Description of problem:
-----------------------
Retain button in the remove-brick status dialog does not work. Clicking on the retain button does not result in the retain brick dialog to open.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.21.beta1.el6_4 

How reproducible:
Always

Steps to Reproduce:
1. Create a cluster with a single storage node ( to avoid BZ #1020325 )
2. Create a distributed-replicate ( replica 2 ) volume and start it.
3. Start remove-brick operation of a pair of bricks and open the status dialog.

Actual results:
After data migration completes, the Retain and Commit button get enabled, but retain button does not work.

Expected results:
Clicking on the retain button should result in the retain bricks dialog to open.

Additional info:
Comment 2 Shruti Sampat 2013-11-28 04:14:46 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.25.master.el6_5.
Comment 4 errata-xmlrpc 2014-02-25 02:58:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.