Bug 1029515 - %scl_install change current directory
%scl_install change current directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: scl-utils (Show other bugs)
6.5
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Jan Zeleny
Lukas Zachar
: ZStream
Depends On: 1011360
Blocks: 1007875 1032451 1033743 1040859 1153512
  Show dependency treegraph
 
Reported: 2013-11-12 09:11 EST by Jan Zeleny
Modified: 2014-10-29 05:52 EDT (History)
8 users (show)

See Also:
Fixed In Version: scl-utils-20120927-9.el6
Doc Type: Bug Fix
Doc Text:
In previous versions of scl-utils, the working directory was changed during package builds, which caused complications to package maintainers. These complications ranged from mild inconveniences to build failures if the code in the spec file worked with the working directory. This bug has been fixed, and the working directory no longer changes during the build time.
Story Points: ---
Clone Of: 1011360
: 1032451 1040859 1153512 (view as bug list)
Environment:
Last Closed: 2014-10-29 05:52:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Zeleny 2013-11-12 09:11:55 EST
+++ This bug was initially created as a clone of Bug #1011360 +++

In %install, after invocation of %scl_install, current directory is %{bulidroot}/%{scl_prefix} which is not common.

I think such macro should not alter the current directory.

Issue.

%prep
generate_some_file  >foo

%install 
install foo %{buildroot}...


The install command fails because "foo" is not found in the current directory.


The current workaound is to install files (ex: the "enable" script) before %scl_install, which doesn't seems correct because
- before %scl_install the SCL tree doesn't exists yet (requiring to create the %{buildroot}%{_scl_scripts} dir first)
- %scl_install is designed to create the SCL tree
- after %scl_install, the SCL tree exists, and so, seems the right place to install additional files.

--- Additional comment from Jan Zeleny on 2013-10-09 14:50:07 CEST ---



--- Additional comment from Fedora Update System on 2013-10-16 09:42:50 CEST ---

scl-utils-20131015-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/scl-utils-20131015-1.fc20

--- Additional comment from Fedora Update System on 2013-10-16 09:43:22 CEST ---

scl-utils-20131015-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scl-utils-20131015-1.fc19

--- Additional comment from Jan Zeleny on 2013-10-16 12:32:53 CEST ---

The "updated update" is here:
https://admin.fedoraproject.org/updates/scl-utils-20131016-1.fc19

--- Additional comment from Jan Zeleny on 2013-10-17 16:22:53 CEST ---

While testing on real-life collections I found one unrelated issue in scl-utils, a new update has been issued:

https://admin.fedoraproject.org/updates/scl-utils-20131017-1.fc19

--- Additional comment from Fedora Update System on 2013-10-17 22:32:50 CEST ---

Package scl-utils-20131017-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scl-utils-20131017-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19205/scl-utils-20131017-1.fc20
then log in and leave karma (feedback).

--- Additional comment from Fedora Update System on 2013-11-10 08:19:38 CET ---

scl-utils-20131017-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Kiersten (Kerri) Anderson 2014-10-15 16:21:11 EDT
rhel-6.4.z to ?, to sync between all active branches, as req'd.
Comment 9 errata-xmlrpc 2014-10-29 05:52:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1730.html

Note You need to log in before you can comment on or make changes to this bug.