Bug 1032451 - %scl_install change current directory
%scl_install change current directory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: scl-utils (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Zeleny
Lukas Zachar
:
Depends On: 1011360 1029515 1040859
Blocks: 1007875
  Show dependency treegraph
 
Reported: 2013-11-20 03:58 EST by Marcela Mašláňová
Modified: 2014-06-18 04:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: scl-utils-20130529-2.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1029515
Environment:
Last Closed: 2014-06-13 09:07:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2013-11-20 03:58:40 EST
+++ This bug was initially created as a clone of Bug #1029515 +++

+++ This bug was initially created as a clone of Bug #1011360 +++

In %install, after invocation of %scl_install, current directory is %{bulidroot}/%{scl_prefix} which is not common.

I think such macro should not alter the current directory.

Issue.

%prep
generate_some_file  >foo

%install 
install foo %{buildroot}...


The install command fails because "foo" is not found in the current directory.


The current workaound is to install files (ex: the "enable" script) before %scl_install, which doesn't seems correct because
- before %scl_install the SCL tree doesn't exists yet (requiring to create the %{buildroot}%{_scl_scripts} dir first)
- %scl_install is designed to create the SCL tree
- after %scl_install, the SCL tree exists, and so, seems the right place to install additional files.
Comment 3 Ludek Smid 2014-06-13 09:07:19 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.