Bug 1029534 - gradle: Retire in Rawhide and in 20
Summary: gradle: Retire in Rawhide and in 20
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gradle
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: gil cattaneo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 958008 976330 992428
TreeView+ depends on / blocked
 
Reported: 2013-11-12 14:41 UTC by Marek Goldmann
Modified: 2013-11-13 07:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-12 16:11:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Marek Goldmann 2013-11-12 14:41:49 UTC
Description of problem:

Since the gradle package is hard to keep up to date and none of the Fedora packages require it ATM, it is safe to retire gradle in Rawhide.

In Fedora 20 there is still one package: hibernate which requires gradle, but it'll change tomorrow (I'll upgrade to Hibernate 4.3), so I would go ahead and retire Gradle there too.

Comment 1 James Heather 2013-11-12 15:59:34 UTC
I don't really understand why this is being retired. It's an important tool in its own right, regardless of whether other Fedora packages depend on it. It gets used a lot for build scripts.

I think Fedora would be worse off for not having it. Could this please be reconsidered?

Comment 2 Fedora Admin XMLRPC Client 2013-11-12 16:04:03 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 gil cattaneo 2013-11-12 16:11:25 UTC
no, sorry

Comment 4 gil cattaneo 2013-11-12 16:19:30 UTC
the causes of withdrawal have already been extensively discussed in the various lists and chat rooms dedicated
again my apologize

Comment 5 Marek Goldmann 2013-11-13 07:57:47 UTC
(In reply to James Heather from comment #1)
> I don't really understand why this is being retired. It's an important tool
> in its own right, regardless of whether other Fedora packages depend on it.
> It gets used a lot for build scripts.
> 
> I think Fedora would be worse off for not having it. Could this please be
> reconsidered?

For reasoning, please refer to the java-devel mailing list and the "[fedora-java] Gradle upgrade issues (#976330)" thread, starting here:

https://lists.fedoraproject.org/pipermail/java-devel/2013-October/004971.html


Note You need to log in before you can comment on or make changes to this bug.