Bug 976330 - gradle: new version 1.6 available
Summary: gradle: new version 1.6 available
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gradle
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: gil cattaneo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1029534
Blocks: 992323
TreeView+ depends on / blocked
 
Reported: 2013-06-20 11:53 UTC by Michael Ekstrand
Modified: 2013-11-12 16:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-12 16:14:09 UTC


Attachments (Terms of Use)

Description Michael Ekstrand 2013-06-20 11:53:30 UTC
Description of problem:
Gradle in Fedora is still at version 1.0, while upstream has released Gradle 1.6.


Version-Release number of selected component (if applicable):
gradle-1.0-13.fc19

Comment 1 gil cattaneo 2013-06-20 12:04:12 UTC
hi,
yes i know but with gradle >=1.3 there is a problem to solve
asm libraries, gradle use internal groovy asm and asm4 on both
and generated a lot of conflicts...
thanks for report this problem

Comment 2 James Heather 2013-10-18 09:38:32 UTC
Hi there,

This is causing me quite a lot of problems too... is there any chance of sorting out upgrading gradle to the latest version? 1.0 is rather old now.

Thanks!

James

Comment 3 Marek Goldmann 2013-10-18 09:48:04 UTC
Gradle causes a lot of troubles in maintaining it, I'm starting to think we should drop this package.

Comment 4 gil cattaneo 2013-10-18 09:49:26 UTC
hi James,
currently gradle on F20 and rawhide is broken
cause: gradle should be ported for use new eclipse aether component
if you want can help us for do this
now we try to import latest (1.7) release
regards

Comment 5 James Heather 2013-10-18 15:01:54 UTC
It would be a big shame to drop it: it's an important part of lots of development projects. It would be great if it could be fixed somehow...


Note You need to log in before you can comment on or make changes to this bug.