Bug 102956 - Entry for spamd (spamassassin) missing in /etc/services
Entry for spamd (spamassassin) missing in /etc/services
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
: 115958 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-23 04:51 EDT by Nils Philippsen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-29 01:18:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2003-08-23 04:51:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030703 Galeon/1.3.7

Description of problem:
Sometimes, RPC services get the port number of the SpamAssassin spamd (783/tcp).
Spamd which gets started later on, fails to bind to the port and doesn't work.
IIRC, portmap doesn't use ports listed in /etc/services, so putting this line in
/etc/services would be a fix of the problem:

spamd           783/tcp                         # SpamAssassin Daemon

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Start system
2. Depending on the moon phase and whatnot, portmap may assign Spamd's port to
one of the RPC services
    

Actual Results:  Spamd didn't start because port 783/tcp was in use.

Expected Results:  Spamd starts

Additional info:
Comment 1 Bill Nottingham 2003-08-23 21:37:15 EDT
spamassassin should register with IANA. :)
Comment 2 Nils Philippsen 2003-08-24 08:00:21 EDT
Indeed it should. But from looking at
http://bugzilla.spamassassin.org/show_bug.cgi?id=480 it seems like this won't
happen soon (someone needs to write up an RFC for the spamd protocol beforehands
which is unlikely to happen soon due to the narrow scope of the protocol). Would
it be better if the spamassassin RPM added the entry as a "local service" to the
end of /etc/services on install?

On the other hand I just noticed that portmap ignores my manual entry in
/etc/services and rpc.mounted again landed on spamd's port... Filed as #102989.
Comment 3 Bill Nottingham 2003-08-24 23:26:23 EDT
Yeah, I didn't think rpc really actaully avoided stuff in /etc/services... it's
landed on the lpr port before. :/
Comment 4 Bill Nottingham 2004-05-04 23:25:52 EDT
*** Bug 115958 has been marked as a duplicate of this bug. ***
Comment 5 Gerald Teschl 2004-05-05 03:07:05 EDT
Same here, adding spamd to /etc/services does not help.
So it looks like the best solution is to just start spamd
before any rpc services.
Comment 6 Warren Togami 2005-04-03 06:33:21 EDT
Is this still an issue with FC3 or FC4?
Comment 7 Nils Philippsen 2005-04-03 06:51:47 EDT
This entry is missing on FC3 and FC4, in the setup as well as in the
spamassassin package. I don't know if anything has changed regarding the
behaviour of bindresvport() and ports listed in /etc/services (see bug #102989).
Comment 8 Warren Togami 2005-04-03 07:36:36 EDT
And btw, why is this filed against spamassassin when /etc/services is owned by
the "setup" package?
Comment 9 Nils Philippsen 2005-04-04 02:49:28 EDT
It was originally with setup, but since the spamassassin port wasn't registered
with IANA (see comments #1 and #2) Bill moved it over to spamassassin itself so
the package would append the port to /etc/services when installed (or something
like that).
Comment 10 Warren Togami 2005-04-04 03:30:46 EDT
Isn't that an awfully fragile way of doing it?
Comment 11 Nils Philippsen 2005-04-04 03:54:52 EDT
Depending on how it's done ;-P. Anyway, unless bug #102989 isn't solved, we
could rather defer the issue, what do you think?
Comment 12 Warren Togami 2005-04-04 03:56:14 EDT
Agreed
Comment 13 Warren Togami 2005-04-29 01:18:39 EDT
Since Bug 102989 is NOTABUG, and this is meaningless without that bug, closing
NOTABUG here.  Please open a new bug if you think of a better solution.

Note You need to log in before you can comment on or make changes to this bug.