Bug 1029577 - dist-geo-rep: It should be logged in the geo-rep logs, when gsync is using tar+ssh as syncing method
dist-geo-rep: It should be logged in the geo-rep logs, when gsync is using ta...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Amar Tumballi
M S Vishwanath Bhat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 11:25 EST by M S Vishwanath Bhat
Modified: 2016-05-31 21:56 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.44rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:47:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description M S Vishwanath Bhat 2013-11-12 11:25:52 EST
Description of problem:
The new option to sync data using tar+ssh instead of rsync should be logged when it is being used. When the use-tarssh is set to true using the geo-rep config CLI, it should be logged in the log file.  Currently only config will have this option displayed. But this bug https://bugzilla.redhat.com/show_bug.cgi?id=1029575 makes the config list unreliable.

But Ideally even log file should say what method is currently being used.



Version-Release number of selected component (if applicable):
glusterfs-3.4.0.43rhs-1.el6rhs.x86_64


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
It's not being logged when the use-tarssh is turned on.

Expected results:
It should log when the use-tarssh method is turned on.

Additional info:
Comment 3 M S Vishwanath Bhat 2013-11-13 11:11:17 EST
Now it is logging.

I used config to set use-tarssh to true and then after some time, I did the reset of this using \!use-tarssh with the config CLI.

Now the grep of log file shows this.

[root@ramanujan ~]# egrep "sync engine"  /var/log/glusterfs/geo-replication/master/ssh%3A%2F%2Froot%4010.70.37.188%3Agluster%3A%2F%2F127.0.0.1%3Aslave.log
[2013-11-13 21:34:13.275118] I [master(/rhs/bricks/brick2):349:__init__] _GMaster: using 'tar over ssh' as the sync engine
[2013-11-13 21:34:13.275573] I [master(/rhs/bricks/brick2):349:__init__] _GMaster: using 'tar over ssh' as the sync engine
[2013-11-13 21:38:08.499425] I [master(/rhs/bricks/brick2):352:__init__] _GMaster: using 'rsync' as the sync engine
[2013-11-13 21:38:08.501183] I [master(/rhs/bricks/brick2):352:__init__] _GMaster: using 'rsync' as the sync engine




[root@pythagoras ~]# egrep "sync engine" /var/log/glusterfs/geo-replication/master/ssh%3A%2F%2Froot%4010.70.37.188%3Agluster%3A%2F%2F127.0.0.1%3Aslave.log
[2013-11-13 21:34:10.496653] I [master(/rhs/bricks/brick0):349:__init__] _GMaster: using 'tar over ssh' as the sync engine
[2013-11-13 21:34:10.497100] I [master(/rhs/bricks/brick0):349:__init__] _GMaster: using 'tar over ssh' as the sync engine
[2013-11-13 21:38:06.304824] I [master(/rhs/bricks/brick0):352:__init__] _GMaster: using 'rsync' as the sync engine
[2013-11-13 21:38:06.306335] I [master(/rhs/bricks/brick0):352:__init__] _GMaster: using 'rsync' as the sync engine


Moving to Verified.
Comment 4 errata-xmlrpc 2013-11-27 10:47:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.