Bug 1029582 - Setting QXL driver on VirtManager for a VM does not set the driver on the VM
Setting QXL driver on VirtManager for a VM does not set the driver on the VM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.0
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: virt-mgr-maint
Virtualization Bugs
:
Depends On:
Blocks: 1029583
  Show dependency treegraph
 
Reported: 2013-11-12 11:32 EST by Vimal Patel
Modified: 2013-11-19 05:12 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1029583 (view as bug list)
Environment:
Last Closed: 2013-11-19 05:12:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Patel 2013-11-12 11:32:02 EST
Description of problem:
After setting the VM with options Display: Spice, Video QXL, Controller: Virtio Serial, and setting the spicevmc Channel, the VM should be setup to display spice and use the qxl driver by default.

However, the VM is still configured to use Vesa drivers in /etc/X11/xorg.conf, so qxl is not set and cannot be used by the client, until it the file is manually changed to qxl or manually deleted (This process should be taken care of by virt-manager) 

Version-Release number of selected component (if applicable):
Host: RHEL 7  RHEL-7.0-20131106.n.1
spice-server-0.12.4-3.el7.x86_64
libvirt-1.1.1-11.el7.x86_64
qemu-kvm-1.5.3-13.el7.x86_64

Guest: RHEL 6.5 RC1.2
spice-vdagent-0.14.0.2-el6.x86_64
xorg-x11-drv-qxl-0.1.0-7.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a VM from Virt-Manager
2. Set all the Spice options from Virt-Manager (Display: Spice, Video QXL, Controller: Virtio Serial, and setting the spicevmc Channel)
3. try to use qxl (automatic resolution match to client in full screen) or verify it is set in /etc/X11/xorg.conf

Actual results:
/etc/X11/xorg.conf points to Vesa drivers instead of qxl
when going to full screen using remote-viewer there is no resolution match to client, because qxl drivers are not set

Expected results:
/etc/X11/xorg.conf points to qxl drivers
when going to full screen using remote-viewer there is a resolution match to the client's resolution.

Additional info:
Comment 2 Martin Kletzander 2013-11-15 04:24:00 EST
This is guest issue (see Bug 1029583).  Could you try reproducing this with RHEL 7 as a guest in order to see whether this is fixed in there?
Comment 3 Vimal Patel 2013-11-18 12:48:54 EST
I tried a couple RHEL 7 installs, the xorg.conf file was not created, so the qxl driver was able to be used correctly by default.

But it still has the issue of if I create an xorg.conf file and set it to a driver that is not qxl, shut the VM down, and change the Video to QXL it won't work because of the existing xorg.conf file.
Comment 4 Martin Kletzander 2013-11-19 05:12:13 EST
There is no issue.  Creating xorg.conf and specifying a driver literally means telling X to use that specified driver no matter whatever happens.  There is no problem in 7.0 then, I'm closing this as NOTABUG.

In case you disagree feel free to open (this or new) bug on the guest's system component which configured the video driver.

Note You need to log in before you can comment on or make changes to this bug.