Bug 1029583 - [Doc] Setting QXL driver on VirtManager for a VM does not set the driver on the VM
[Doc] Setting QXL driver on VirtManager for a VM does not set the driver on t...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Administration_Guide (Show other bugs)
6.5
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Jiri Herrmann
ecs-bugs
: Documentation, Triaged
Depends On: 1029582
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 11:33 EST by Vimal Patel
Modified: 2016-05-30 12:47 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1029582
Environment:
Last Closed: 2016-05-30 12:47:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Patel 2013-11-12 11:33:58 EST
+++ This bug was initially created as a clone of Bug #1029582 +++

Description of problem:
After setting the VM with options Display: Spice, Video QXL, Controller: Virtio Serial, and setting the spicevmc Channel, the VM should be setup to display spice and use the qxl driver by default.

However, the VM is still configured to use Vesa drivers in /etc/X11/xorg.conf, so qxl is not set and cannot be used by the client, until it the file is manually changed to qxl or manually deleted (This process should be taken care of by virt-manager) 

Version-Release number of selected component (if applicable):
Host: RHEL 7  RHEL-7.0-20131106.n.1
spice-server-0.12.4-3.el7.x86_64
libvirt-1.1.1-11.el7.x86_64
qemu-kvm-1.5.3-13.el7.x86_64

Guest: RHEL 6.5 RC1.2
spice-vdagent-0.14.0.2-el6.x86_64
xorg-x11-drv-qxl-0.1.0-7.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create a VM from Virt-Manager
2. Set all the Spice options from Virt-Manager (Display: Spice, Video QXL, Controller: Virtio Serial, and setting the spicevmc Channel)
3. try to use qxl (automatic resolution match to client in full screen) or verify it is set in /etc/X11/xorg.conf

Actual results:
/etc/X11/xorg.conf points to Vesa drivers instead of qxl
when going to full screen using remote-viewer there is no resolution match to client, because qxl drivers are not set

Expected results:
/etc/X11/xorg.conf points to qxl drivers
when going to full screen using remote-viewer there is a resolution match to the client's resolution.

Additional info:
Comment 2 Martin Kletzander 2013-11-15 04:23:03 EST
This is not something the host should be doing.  There are couple of possibilities on how this can be solved, but all of them should be taken care of in the guest OS; as any other HW change, the guest should reflect the change by reconfiguring itself properly.  Host cannot be responsible for such things.

IMO, I think this should be handled by whatever application saves the xorg.conf file.  A workaround may be done in spice-vdagent, but that doesn't seem as a clean way to me.

Looking at the docs, it looks like there shouldn't be any xorg.conf.  If needed (by a certain situation), it can be created and then it should be honored and not changed automatically.  Did you create it yourself (a) or (b) was it created automatically for you?  If (a), then this is not a bug, if (b), then this bug needs to be transferred to the component which created it.
Comment 3 Dave Allan 2013-11-15 08:09:13 EST
Vimal, I agree with Martin that what you're requesting is outside the scope of virt-manager.  Typically the guest OS installer takes care of configuring things correctly.
Comment 5 Vimal Patel 2013-11-15 16:40:45 EST
I did not create the xorg.conf file, it was already there after VM creation. 
Then, changing the Video driver to qxl has no impact because of the existing xorg.conf file.  I had to manually delete it or change it to qxl.
Comment 6 Martin Kletzander 2013-11-17 13:30:09 EST
So then it needs to be transferred to the application which created the xorg.conf file.  I'm almost sure anaconda doesn't do that, but the same applies for others, so I'm moving this to the installer team at least to identify whether they do this or not.  I don't know what else to suspect apart from anaconda.
Comment 7 Vimal Patel 2013-12-11 11:33:44 EST
Changing to a doc bug on the Virtualization Administration Guide.  After some research, the RHEVM documentation describes the procedure of how qxl should work, and be configured.  Which is to install the driver and modify the xorg.conf file; however, this is not mentioned in the Virtualization Administration Guide in regards to virt-manager.

In the RHEVM 3.2 Administration Guide, the sections are:
8.13.2.1
8.13.2.2
8.13.2.3
Comment 12 Andrei Stepanov 2016-05-30 12:47:50 EDT
At this moment xorg.conf is absent and is not created during RHEL6/7 installation. 

According to: https://access.redhat.com/solutions/5263

Red Hat Enterprise Linux 6 and above may not create xorg.conf, and usually do not require the same for a functional display, as this is managed using haldaemon.

Note You need to log in before you can comment on or make changes to this bug.