Bug 1029630 - ValueError: new size same as old size
ValueError: new size same as old size
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
All Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Lehman
Release Test Team
abrt_hash:611cdb9be933cf4c49780484ed7...
:
: 918454 (view as bug list)
Depends On: 1027947
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 14:14 EST by David Lehman
Modified: 2014-06-17 21:43 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-19.31.45-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1027947
Environment:
Last Closed: 2014-06-13 06:44:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-11-12 14:14:33 EST
+++ This bug was initially created as a clone of Bug #1027947 +++

Description of problem:
I had old LVM partition scheme on my disk. I have resized old root partition to some big number (130 GB on my 20 GB disk), accepted changes (ran without problem), and then tried to resize it back to old value and this showed up.

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 581, in __init__
    raise ValueError("new size same as old size")
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1250, in resizeDevice
    self.devicetree.registerAction(action_class(device, new_size))
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1454, in _save_right_side
    self.__storage.resizeDevice(device, size)
  File "/usr/lib/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2802, in on_apply_clicked
    self._save_right_side(self._current_selector)
ValueError: new size same as old size

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20i386 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.i686
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta

Potential duplicate: bug 868698


--- Additional comment from Jan Sedlák on 2013-11-07 08:54:20 EST ---

Steps to reproduce:

1. Install Fedora using default LVM partition scheme.
2. Boot F20 anaconda installer.
3. Choose custom partitioning.
4. Resize existing root partition to bigger size than your disk have (130 GB) and click "update settings". It shows that root will have 130 GB.
5. Resize your root partition back to old size.
Comment 1 David Lehman 2014-01-13 15:39:22 EST
*** Bug 918454 has been marked as a duplicate of this bug. ***
Comment 2 David Lehman 2014-01-14 12:00:11 EST
Perhaps I should not have closed 918454 as a duplicate of this bug. This one uses LVM and that one uses a disk partition.
Comment 4 Jan Stodola 2014-02-14 04:04:27 EST
Reproduced with anaconda-19.31.42-1.el7, verified with anaconda-19.31.56-1.el7.
Anaconda doesn't allow LV sizes bigger than VG size.

Moving to VERIFIED.
Comment 5 Ludek Smid 2014-06-13 06:44:40 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.