Bug 868698 - ValueError: new size same as old size
ValueError: new size same as old size
Status: CLOSED DUPLICATE of bug 872446
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:611cdb9be933cf4c49780484ed7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-21 16:20 EDT by Reartes Guillermo
Modified: 2012-11-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-02 19:40:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (222.50 KB, text/plain)
2012-10-21 16:20 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-10-21 16:20 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-10-21 16:20 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (2.09 KB, text/plain)
2012-10-21 16:20 EDT, Reartes Guillermo
no flags Details
File: storage.log (67.24 KB, text/plain)
2012-10-21 16:20 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-10-21 16:20 EDT, Reartes Guillermo
no flags Details
File: environ (780 bytes, text/plain)
2012-10-21 16:20 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (16.13 KB, text/plain)
2012-10-21 16:20 EDT, Reartes Guillermo
no flags Details
File: syslog (73.58 KB, text/plain)
2012-10-21 16:21 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-21 16:21 EDT, Reartes Guillermo
no flags Details
File: packaging.log (2.38 KB, text/plain)
2012-10-21 16:21 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-10-21 16:21 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-10-21 16:21 EDT, Reartes Guillermo
no flags Details
File: program.log (31.83 KB, text/plain)
2012-10-21 16:21 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-21 16:20:32 EDT
Description of problem:
go to manual paritioning, with a disk with a previous f18 intance (in my case)
delete one partition
select one partition, change its size to a ridiculous big amount,  aconda correclty refuses such size.
select one partition, change its size to zero, aconda correclty refuses such size.
select one partition, change its size to a ridiculous big amount,  aconda crashes!


Version-Release number of selected component:
anaconda-18.19

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.19 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 355, in __init__
:    raise ValueError("new size same as old size")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1261, in resizeDevice
:    self.devicetree.registerAction(action_class(device, new_size))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1097, in _save_right_side
:    self.__storage.resizeDevice(device, size)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1994, in on_apply_clicked
:    self._save_right_side(self._current_selector)
:ValueError: new size same as old size
Comment 1 Reartes Guillermo 2012-10-21 16:20:40 EDT
Created attachment 631033 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-10-21 16:20:43 EDT
Created attachment 631035 [details]
File: product
Comment 3 Reartes Guillermo 2012-10-21 16:20:45 EDT
Created attachment 631036 [details]
File: type
Comment 4 Reartes Guillermo 2012-10-21 16:20:47 EDT
Created attachment 631037 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-10-21 16:20:50 EDT
Created attachment 631038 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-10-21 16:20:52 EDT
Created attachment 631039 [details]
File: version
Comment 7 Reartes Guillermo 2012-10-21 16:20:54 EDT
Created attachment 631040 [details]
File: environ
Comment 8 Reartes Guillermo 2012-10-21 16:20:57 EDT
Created attachment 631041 [details]
File: anaconda.log
Comment 9 Reartes Guillermo 2012-10-21 16:21:01 EDT
Created attachment 631042 [details]
File: syslog
Comment 10 Reartes Guillermo 2012-10-21 16:21:03 EDT
Created attachment 631043 [details]
File: hashmarkername
Comment 11 Reartes Guillermo 2012-10-21 16:21:05 EDT
Created attachment 631044 [details]
File: packaging.log
Comment 12 Reartes Guillermo 2012-10-21 16:21:07 EDT
Created attachment 631045 [details]
File: cmdline_file
Comment 13 Reartes Guillermo 2012-10-21 16:21:09 EDT
Created attachment 631046 [details]
File: release
Comment 14 Reartes Guillermo 2012-10-21 16:21:12 EDT
Created attachment 631047 [details]
File: program.log
Comment 15 Brian Lane 2012-11-02 19:40:34 EDT

*** This bug has been marked as a duplicate of bug 872446 ***

Note You need to log in before you can comment on or make changes to this bug.