Bug 10297 - resolv.conf
resolv.conf
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
:
: 10293 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-21 23:28 EST by r.sanders
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-16 12:27:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description r.sanders 2000-03-21 23:28:15 EST
resolv.conf entries lost across boot. I reported this problem earlier
today and it appeared to be a problem with ifup-post. After correcting
ifup-post with no change in the behavior, I installed the updates for the
init scripts off your support page. Still no change. Next, I reinstalled
Linux replacing the custom install with a standard work station install.
Still no change, the resolv.conf is zapped when Linux is rebooted. I have
recursivly greped all directories looking for text strings associated
with "resolv" and with the entries that are showing up in my resolv.conf
file. Nothing found other than ifup-post. I can only assume that some
executable driven at startup is responsible for the problem. The end
result of this is that the resolv.conf file must be manually reconstructed
after reboot of Linux before any host names can be resolved. Could it be
somehow related to the DHCP client? You can call me at 509-893-7404 if you
have questions about my configuration.
Comment 1 Jeff Johnson 2000-03-22 11:10:59 EST
*** Bug 10293 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2000-05-16 12:17:59 EDT
pump is editing the resolv.conf file - reassigned to pump.
Comment 3 Erik Troan 2000-05-16 12:25:59 EDT
You can turn off pump's mucking with /etc/resolv.conf by creating an
/etc/pump.conf that looks like this:

---------
device eth0 {
    nodns
}
---------

"man pump" documents the pump.conf file format.

Note You need to log in before you can comment on or make changes to this bug.