Bug 1029761 - virt-viewer can not get the perfect screenshot of the secondary displays
Summary: virt-viewer can not get the perfect screenshot of the secondary displays
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1029765
TreeView+ depends on / blocked
 
Reported: 2013-11-13 07:04 UTC by CongDong
Modified: 2015-03-05 13:40 UTC (History)
9 users (show)

Fixed In Version: spice-gtk-0.22-1.el7
Doc Type: Bug Fix
Doc Text:
When taking a screenshot of a secondary screen (menu: File > Screenshot), the resulting image was corrupted. After this fix, the resulting image is an accurate representation of the display.
Clone Of:
: 1029765 (view as bug list)
Environment:
Last Closed: 2015-03-05 13:40:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
virt-viewer log : screenshot for display without icons (220.16 KB, text/x-log)
2013-11-13 07:08 UTC, CongDong
no flags Details
the bad screenshot (115.81 KB, image/jpeg)
2013-11-13 07:08 UTC, CongDong
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0297 0 normal SHIPPED_LIVE spice-gtk bug fix and enhancement update 2015-03-05 17:33:27 UTC

Description CongDong 2013-11-13 07:04:19 UTC
Description of problem:
virt-viewer can not get the perfect screenshot of the display without desktop icons.
No problems with screenshot of the display with desktop icons.


Version-Release number of selected component (if applicable):
spice-glib-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-xpi-2.8-4.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a spice guest with  two displays
2. # virsh start vm1
3. # virt-viewer vm1
4. Open all the displays of the guest
5. On the guest display without desktop icons:
   File -> Screenshot -> Save(can save it with ".jpg", ".png", ".bmp")
6. On the guest display with desktop icons:
   File -> Screenshot -> Save(can save it with ".jpg", ".png", ".bmp")

Actual results:
Step 5. The screenshot of the display without icons is black background with some white lines
Step 5. screenshot for display with icons is perfect.
".jpg", ".png", ".bmp" all have the problems

Expected results:
Every display can get the perfect screenshot.


Additional info:

Comment 1 CongDong 2013-11-13 07:08:11 UTC
Created attachment 823273 [details]
virt-viewer log : screenshot for display without icons

Sorry there is a typo, correct it:

> Step 5. screenshot for display with icons is perfect.
> ".jpg", ".png", ".bmp" all have the problems

 Step 6. screenshot for display with icons is perfect.
 ".jpg", ".png", ".bmp" all have the problems

Comment 2 CongDong 2013-11-13 07:08:59 UTC
Created attachment 823274 [details]
the bad screenshot

Comment 4 hyao@redhat.com 2013-11-20 07:11:14 UTC
I can reproduce the bug with the following packages: 
[root@7-204 images]# rpm -qa virt-viewer spice*
spice-gtk-0.20-11.el6.x86_64
spice-server-0.12.4-6.el6.x86_64
spice-gtk-python-0.20-11.el6.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-glib-0.20-11.el6.x86_64

The screenshot of the desktop without icon is not perfect.

Comment 5 hyao@redhat.com 2013-11-20 07:15:27 UTC
(In reply to hyao@redhat.com from comment #4)
> I can reproduce the bug with the following packages: 
> [root@7-204 images]# rpm -qa virt-viewer spice*
> spice-gtk-0.20-11.el6.x86_64
> spice-server-0.12.4-6.el6.x86_64
> spice-gtk-python-0.20-11.el6.x86_64
> virt-viewer-0.5.6-8.el6.x86_64
> spice-vdagent-0.14.0-2.el6.x86_64
> spice-glib-0.20-11.el6.x86_64
> 
> The screenshot of the desktop without icon is not perfect.


Please ignore the comment4 with wrong package listed. Reproduced the bug with the package below:
[root@5-255 images]# rpm -qa virt-viewer spice*
spice-glib-0.20-6.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
spice-xpi-2.8-4.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-gtk-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64

Can't get a perfect screenshot of the desktop without icons

Comment 6 Marc-Andre Lureau 2014-03-12 22:58:49 UTC
I can reproduce some screenshot issues, taking

Comment 9 Jonathon Jongsma 2014-07-07 20:39:12 UTC
Since the patch involved spice-gtk, moving it to that component

Comment 13 errata-xmlrpc 2015-03-05 13:40:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0297.html


Note You need to log in before you can comment on or make changes to this bug.