Bug 1029765 - virt-viewer can not get the perfect screenshot of the display without icons
virt-viewer can not get the perfect screenshot of the display without icons
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On: 1029761
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-13 02:15 EST by CongDong
Modified: 2014-10-14 02:46 EDT (History)
11 users (show)

See Also:
Fixed In Version: spice-gtk-0.22-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: Taking screenshot on secondary displays. Consequence: The screenshot is invalid. Fix: Screenshot memory region for secondary displays. Result: The screenshot is correct.
Story Points: ---
Clone Of: 1029761
Environment:
Last Closed: 2014-10-14 02:46:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongDong 2013-11-13 02:15:01 EST
+++ This bug was initially created as a clone of Bug #1029761 +++

This bug can be reproduce on RHEL6.5 with:
# rpm -qa virt-viewer spice*
spice-glib-0.20-11.el6.x86_64
spice-server-0.12.4-6.el6.x86_64
spice-gtk-python-0.20-11.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-gtk-0.20-11.el6.x86_64
virt-viewer-0.5.6-8.el6.x86_64

So clone the bug.

Description of problem:
virt-viewer can not get the perfect screenshot of the display without desktop icons.
No problems with screenshot of the display with desktop icons.


Version-Release number of selected component (if applicable):
spice-glib-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-xpi-2.8-4.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Prepare a spice guest with  two displays
2. # virsh start vm1
3. # virt-viewer vm1
4. Open all the displays of the guest
5. On the guest display without desktop icons:
   File -> Screenshot -> Save(can save it with ".jpg", ".png", ".bmp")
6. On the guest display with desktop icons:
   File -> Screenshot -> Save(can save it with ".jpg", ".png", ".bmp")

Actual results:
Step 5. The screenshot of the display without icons is black background with some white lines
Step 5. screenshot for display with icons is perfect.
".jpg", ".png", ".bmp" all have the problems

Expected results:
Every display can get the perfect screenshot.


Additional info:

--- Additional comment from CongDong on 2013-11-13 02:08:11 EST ---

Sorry there is a typo, correct it:

> Step 5. screenshot for display with icons is perfect.
> ".jpg", ".png", ".bmp" all have the problems

 Step 6. screenshot for display with icons is perfect.
 ".jpg", ".png", ".bmp" all have the problems

--- Additional comment from CongDong on 2013-11-13 02:08:59 EST ---
Comment 1 hyao@redhat.com 2013-11-20 02:06:38 EST
I can reproduce the bug with the following packages: 
[root@7-204 images]# rpm -qa virt-viewer spice*
spice-gtk-0.20-11.el6.x86_64
spice-server-0.12.4-6.el6.x86_64
spice-gtk-python-0.20-11.el6.x86_64
virt-viewer-0.5.6-8.el6.x86_64
spice-vdagent-0.14.0-2.el6.x86_64
spice-glib-0.20-11.el6.x86_64

The screenshot of the desktop without icon is not perfect.
Comment 2 Marc-Andre Lureau 2014-04-03 07:42:32 EDT
bug 1029761 in POST.
Comment 6 errata-xmlrpc 2014-10-14 02:46:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1487.html

Note You need to log in before you can comment on or make changes to this bug.