Bug 1030001 - [RFE] Create Subscription Manager CLI preferences module
[RFE] Create Subscription Manager CLI preferences module
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.1
Assigned To: candlepin-bugs
John Sefler
: FutureFeature
: 990182 (view as bug list)
Depends On:
Blocks: rhsm-rhel72
  Show dependency treegraph
 
Reported: 2013-11-13 11:43 EST by Matt Reid
Modified: 2015-05-06 14:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-06 14:37:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2013-11-13 11:43:02 EST
Description of problem:
At this point we have several different modules which control subscription manager preferences. In the GUI we have them in one window. In the CLI, we have 3 main preference modules that are scattered throughout the primary and other modules sections in help. In an effort to cut down on the number of modules we have (we've got more than 20 already), and make it easier to find what they're looking for without skimming through 20+ modules and their descriptions, we might be able to cut out our current preference/settings modules and move them into their own preferences module. That way when we have to add more preferences in the future (which I imagine we will at some point), we don't have to create an additional module for each one.

Might be able to put config in there as well, and a proxy module if we ever pull it out of all the other modules and give it its own home.

Here's what we currently have for modules:

    Usage: subscription-manager MODULE-NAME [MODULE-OPTIONS] [--help]
     
    Primary Modules:
     
      attach         Attach a specified subscription to the registered system
      list           List subscription and product information for this system
      refresh        Pull the latest subscription data from the server
      register       Register this system to the Customer Portal or another subscription management service
      release        Configure which operating system release to use [PREFERENCE]
      remove         Remove all or specific subscriptions from this system
      status         Show status information for this system's subscriptions and products
      unregister     Unregister this system from the Customer Portal or another subscription management service
     
    Other Modules:
     
      auto-attach    Set if subscriptions are attached on a schedule (default of daily) [PREFERENCE]
      clean          Remove all local system and subscription data without affecting the server
      config         List, set, or remove the configuration parameters in use by this system
      environments   Display the environments available for a user
      facts          View or update the detected system information
      identity       Display the identity certificate for this system or request a new one
      import         Import certificates which were provided outside of the tool
      orgs           Display the organizations against which a user can register a system
      repo-override  Manage custom content repository settings
      plugins        View and configure subscription-manager plugins
      redeem         Attempt to redeem a subscription for a preconfigured system
      repos          List the repositories which this system is entitled to use
      service-level  Manage service levels for this system [PREFERENCE]
      subscribe      Deprecated, see attach
      unsubscribe    Deprecated, see remove
      version        Print version information

Additional info:
If it isn't possible to have modules in modules, maybe we should at least consider adding in a Preference Modules: section and listing them together, instead of scattering them across Primary and Other.
Comment 1 Carter Kozak 2014-01-06 09:24:37 EST
This seems like a good idea, however in the past we have avoided making similar changes because they might break scripts.  If we leave legacy modules, we're compounding the problem.

Thoughts?
Comment 2 Bryan Kearney 2014-01-17 09:51:46 EST
Not going to go into 7.0.
Comment 3 William Poteat 2014-01-24 14:03:32 EST
*** Bug 990182 has been marked as a duplicate of this bug. ***
Comment 5 Bryan Kearney 2014-07-30 15:21:42 EDT
Acking 7.1

Note You need to log in before you can comment on or make changes to this bug.