Bug 990182 - Rectify CLI commands "auto-attach" and "attach --auto"
Rectify CLI commands "auto-attach" and "attach --auto"
Status: CLOSED DUPLICATE of bug 1030001
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: William Poteat
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2013-07-30 10:22 EDT by Devan Goodwin
Modified: 2014-01-24 14:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-24 14:03:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2013-07-30 10:22:07 EDT
Description of problem:

We started with subscribe --auto, which became attach --auto. This asks the server to figure out the best entitlements and give them to us.

Then we went to add an autoheal module which controls the server side flag, which indicates if this system should try to heal (essentially running "attach --auto" every 24 hours by default). We can't say heal, so this became auto-attach. 

There's also "register --auto-attach", though this is a register followed by an attach --auto, so what to do here will be determined by sorting out the other two.

This is highly confusing as both of these commands do entirely different things. Need to figure out a way to cover the functionality without describing it exactly the same.

Version-Release number of selected component (if applicable):

subscription-manager-1.8.13-1
Comment 2 William Poteat 2014-01-24 14:03:32 EST

*** This bug has been marked as a duplicate of bug 1030001 ***

Note You need to log in before you can comment on or make changes to this bug.