This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1030454 - X doesn't start with nomodeset and GOP driver (Windows 8 Feature)
X doesn't start with nomodeset and GOP driver (Windows 8 Feature)
Status: CLOSED DUPLICATE of bug 1030695
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-14 08:37 EST by Kamil Páral
Modified: 2013-11-18 11:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 11:24:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (8.71 KB, text/plain)
2013-11-14 08:38 EST, Kamil Páral
no flags Details
journal (168.93 KB, text/plain)
2013-11-14 08:38 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-11-14 08:37:39 EST
Description of problem:
I have an MSI Z77A-G45 GAMING motherboard. When I boot F20 Beta Live in UEFI mode and start the system with "nomodeset" boot option (to enforce safe graphics mode), everything works correctly and Xorg uses "vesa" driver (I heard something about efifb, but according to X log vesa is used).

Now, if I go to UEFI BIOS and enable "Windows 8 Feature", a new "Internal GOP Configuration" option appears. I can't really configure in there anything (it seems I would be able to configure a primary display if I had more of them), I just see that I have "Intel GOP Driver [3.0.14.1015]" (Ivy Bridge). Now when I try to boot again with "nomodeset", X fails to start with:

> [     8.627] (EE) Screen(s) found, but none have a usable configuration.

Without nomodeset, everything works fine (intel driver is used).

I have no knowledge in this field, but it seems that "GOP" (whatever that is) breaks X in the safe graphics mode.

Version-Release number of selected component (if applicable):
Fedora 20 Beta Live x86_64
xorg-x11-server-Xorg-1.14.3-4.fc20.x86_64
xorg-x11-drv-vesa-2.3.2-10.fc20.x86_64
xorg-x11-drv-modesetting-0.8.0-2.fc20.x86_64
xorg-x11-drv-intel-2.21.15-4.fc20.x86_64
xorg-x11-drv-fbdev-0.4.3-10.fc20.x86_64


How reproducible:
always

Steps to Reproduce:
1. enable "Windows 8 Feature", GOP option appears
2. boot in UEFI mode, add "nomodeset" to force safe graphics mode
3. see X fail to start
Comment 1 Kamil Páral 2013-11-14 08:38:07 EST
Created attachment 823958 [details]
Xorg.0.log
Comment 2 Kamil Páral 2013-11-14 08:38:13 EST
Created attachment 823959 [details]
journal
Comment 3 Kamil Páral 2013-11-18 11:24:19 EST

*** This bug has been marked as a duplicate of bug 1030695 ***

Note You need to log in before you can comment on or make changes to this bug.