Bug 1030695 - no safe graphics on EFI with nomodeset
no safe graphics on EFI with nomodeset
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 1030454 (view as bug list)
Depends On:
Blocks: F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-11-14 19:18 EST by Chris Murphy
Modified: 2013-11-19 16:54 EST (History)
5 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.14.4-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-19 16:54:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (9.09 KB, text/plain)
2013-11-14 19:18 EST, Chris Murphy
no flags Details
lspci -vvnn (41.85 KB, text/plain)
2013-11-15 16:28 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-11-14 19:18:40 EST
Created attachment 824185 [details]
Xorg.0.log

Description of problem: When booting an EFI Mac with nomodeset, safe graphics mode isn't available, only text boot occurs. Seems to be a regression.


Version-Release number of selected component (if applicable):
Fedora 20 beta (final)
xorg-x11-server-1.14.3-4.fc20.src.rpm  


How reproducible:
Always, on two EFI Macs. One has nvidia graphics, the other hand dual intel/radeon graphics.

Steps to Reproduce:
Boot with nomodeset param.

Actual results:
tty1 hangs at gnome-shell, no graphics. I can switch to tty2 and get a login prompt.

Expected results:
To see GDM, login, etc.


Additional info:
Worked with xorg-x11-server-1.14.2-3.fc19.uefi1.src.rpm per 
http://koji.fedoraproject.org/koji/taskinfo?taskID=5596647
https://lists.fedoraproject.org/pipermail/test/2013-July/116930.html
Comment 1 Chris Murphy 2013-11-15 16:28:24 EST
Created attachment 824716 [details]
lspci -vvnn
Comment 2 Chris Murphy 2013-11-15 16:29:00 EST
Tested models:

Macbook Pro 4,1 has UGA graphics
NVIDIA Corporation G84M [GeForce 8600M GT] [10de:0407] (rev a1) (prog-if 00 [VGA controller])

Macbook Pro 8,2 has GOP graphics
Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])
Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M] [1002:6741] (prog-if 00 [VGA controller])
Comment 3 Fedora Blocker Bugs Application 2013-11-16 13:00:49 EST
Proposed as a Blocker for 20-final by Fedora user chrismurphy using the blocker tracking app because:

 Alpha Release Criterion: "The boot menu for all supported installer and live images should include an entry which causes both installation and the installed system to use a generic, highly compatible video driver (such as 'vesa'). This mechanism should work correctly, launching the installer or
desktop and attempting to use the generic driver."

Could be a Mac EFI edge case, but considering it was working with an earlier version, I suspect other UEFI hardware will be affected.
Comment 4 Kamil Páral 2013-11-18 11:24:19 EST
*** Bug 1030454 has been marked as a duplicate of this bug. ***
Comment 5 Kamil Páral 2013-11-18 11:26:08 EST
This does not affect only Macs, see bug 1030454. Ajax should have a fix soon:

<ajax> building a fix now
<ajax> explaining only delays that

:-)
Comment 6 Kamil Páral 2013-11-18 11:53:13 EST
This build should fix the problem:

http://koji.fedoraproject.org/koji/taskinfo?taskID=6194121
Comment 7 Chris Murphy 2013-11-18 14:16:47 EST
xorg-x11-server-Xorg-1.14.4-4.fc20.x86_64 fixes the problem on Macbook Pro 4,1.
Comment 8 Chris Murphy 2013-11-18 14:43:06 EST
Also fixes the problem on Macbook Pro 8,2. So at least one case each of UGA and GOP graphics fixed.
Comment 9 Fedora Update System 2013-11-18 17:44:23 EST
xorg-x11-server-1.14.4-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.14.4-4.fc20
Comment 10 Fedora Update System 2013-11-19 16:54:46 EST
xorg-x11-server-1.14.4-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.