Bug 1030672 - dynamic_ownership variable is wrong
dynamic_ownership variable is wrong
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Configuration_Reference_Guide (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
: Documentation
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-11-14 17:21 EST by Summer Long
Modified: 2014-01-07 00:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-05 22:40:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1251241 None None None Never

  None (edit)
Description Summer Long 2013-11-14 17:21:53 EST
Description of problem:
https://bugs.launchpad.net/openstack-manuals/+bug/1251241

Currently the guide recommends setting dynamic_ownership to 0, speaking with one of the libvirt developers - and coincidentally developer of the Nova libvirt driver - (Dan Berrange) it appears there is no reason to do this in OpenStack. In fact setting this option to 0 causes permissions issues when attempting migration.

Since the guide provides no justification for this choice, nor any workaround for the permissions issues, I recommend removing this step and leaving dynamic_ownership as the default (1).

URL: http://docs.openstack.org/trunk/config-reference/content/configuring-openstack-compute-basics.html

ToDo: Update in RH CRG for 4.0 release, copy to upstream.
Comment 2 Summer Long 2013-11-27 19:34:33 EST
Commented out the paragraph; waiting for Deepti to do Gerrit review.
Comment 3 Summer Long 2013-11-27 19:55:20 EST
Reviewed; changes merged upstream. Ready for QE when package is on test server.

Note You need to log in before you can comment on or make changes to this bug.