Bug 103071 - openssl-devel missing "Requires: zlib-devel"
openssl-devel missing "Requires: zlib-devel"
Status: CLOSED DUPLICATE of bug 102962
Product: Red Hat Linux Beta
Classification: Retired
Component: openssl (Show other bugs)
beta1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-26 08:02 EDT by Michael Schwendt
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2003-08-26 08:02:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
In openssl-devel package, the pkg-config template /usr/lib/pkgconfig/openssl.pc
(which should not be executable, btw) provides linker options which link against
libz, but neither openssl nor openssl-devel depend on the zlib-devel package. 

Hence applications, which depend on openssl-devel, fail to link against libz due
to incomplete build requirements.

openssl-devel should "Requires: zlib-devel"


Version-Release number of selected component (if applicable):
openssl-devel-0.9.7a-16

How reproducible:
Always
Comment 1 Michael Schwendt 2003-08-26 08:41:32 EDT

*** This bug has been marked as a duplicate of 102962 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.