Bug 102962 - Missing Requires for -devel package
Summary: Missing Requires for -devel package
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: openssl   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 103071 110759 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-08-23 14:47 UTC by Dams
Modified: 2007-04-18 16:57 UTC (History)
3 users (show)

Fixed In Version: 0.9.7a-25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-24 19:11:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dams 2003-08-23 14:47:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
[root@gruyere ~]# pkg-config openssl --libs
-L/usr/kerberos/lib -lssl -lcrypto -lresolv -lgssapi_krb5 -lkrb5 -lk5crypto
-lcom_err -ldl -lz

Notice the -lz

[root@gruyere ~]# rpm -qpR openssl-devel-0.9.7a-17.i386.rpm
krb5-devel
openssl = 0.9.7a-17
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
[root@gruyere ~]#

There should be an explicit 'Requires:zlib-devel' in spec file for -devel package.


Version-Release number of selected component (if applicable):
0.9.7a-17

How reproducible:
Always

Steps to Reproduce:
1. none


Additional info:

Comment 1 Michael Schwendt 2003-08-26 12:41:34 UTC
*** Bug 103071 has been marked as a duplicate of this bug. ***

Comment 2 Nalin Dahyabhai 2003-10-24 19:11:11 UTC
Fixing for 0.9.7a-25 and later.  Thanks!

Comment 3 Nalin Dahyabhai 2003-11-24 15:03:06 UTC
*** Bug 110759 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.