Bug 1030836 - PartitionException: Partition is not part of the disk it is being removed from
PartitionException: Partition is not part of the disk it is being removed from
Status: CLOSED DUPLICATE of bug 1029628
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Lehman
Release Test Team
abrt_hash:a307e4d5f492c5748e9fcde04f5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 04:35 EST by Petr Sklenar
Modified: 2013-12-16 15:19 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 15:19:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (891.97 KB, text/plain)
2013-11-15 04:35 EST, Petr Sklenar
no flags Details
File: anaconda.log (53.20 KB, text/plain)
2013-11-15 04:35 EST, Petr Sklenar
no flags Details
File: environ (405 bytes, text/plain)
2013-11-15 04:35 EST, Petr Sklenar
no flags Details
File: lsblk_output (1.23 KB, text/plain)
2013-11-15 04:35 EST, Petr Sklenar
no flags Details
File: nmcli_dev_list (455 bytes, text/plain)
2013-11-15 04:35 EST, Petr Sklenar
no flags Details
File: os_info (397 bytes, text/plain)
2013-11-15 04:35 EST, Petr Sklenar
no flags Details
File: program.log (27.71 KB, text/plain)
2013-11-15 04:35 EST, Petr Sklenar
no flags Details
File: storage.log (145.46 KB, text/plain)
2013-11-15 04:35 EST, Petr Sklenar
no flags Details
File: syslog (97.08 KB, text/plain)
2013-11-15 04:36 EST, Petr Sklenar
no flags Details
File: ifcfg.log (2.65 KB, text/plain)
2013-11-15 04:36 EST, Petr Sklenar
no flags Details
File: packaging.log (426.84 KB, text/plain)
2013-11-15 04:36 EST, Petr Sklenar
no flags Details

  None (edit)
Description Petr Sklenar 2013-11-15 04:35:21 EST
Description of problem:
0, custom partioning
1, add disk
2, unselect disk, DONE
3, custom partioning, create some random partions
4, go to step 0 until you will see bug

Version-Release number of selected component:
anaconda-19.31.34-1

The following was filed automatically by anaconda:
anaconda 19.31.34-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 269, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 591, in removeNewPartitions
    part.disk.format.partedDisk.removePartition(part.partedPartition)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 780, in doPartitioning
    removeNewPartitions(disks, partitions)
  File "/usr/lib/python2.7/site-packages/blivet/partitioning.py", line 320, in doAutoPartition
    doPartitioning(storage)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 260, in execute
    doAutoPartition(storage, ksdata)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py", line 1731, in doKickstartStorage
    ksdata.autopart.execute(storage, ksdata, instClass)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 402, in _doExecute
    doKickstartStorage(self.storage, self.data, self.instclass)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
PartitionException: Partition is not part of the disk it is being removed from

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/65071/initrd method=http://download-01.eng.brq.redhat.com/pub/rhel/nightly/RHEL-7.0-20131114.n.0/compose/Workstation/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/rhel/nightly/RHEL-7.0-20131114.n.0/compose/Workstation/x86_64/os/  BOOT_IMAGE=/distrotrees/65071/kernel 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-49.el7.x86_64
product:        Red Hat Enterprise Linux
release:        Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)
type:           anaconda
version:        7.0
Comment 1 Petr Sklenar 2013-11-15 04:35:28 EST
Created attachment 824376 [details]
File: anaconda-tb
Comment 2 Petr Sklenar 2013-11-15 04:35:32 EST
Created attachment 824377 [details]
File: anaconda.log
Comment 3 Petr Sklenar 2013-11-15 04:35:35 EST
Created attachment 824378 [details]
File: environ
Comment 4 Petr Sklenar 2013-11-15 04:35:40 EST
Created attachment 824379 [details]
File: lsblk_output
Comment 5 Petr Sklenar 2013-11-15 04:35:46 EST
Created attachment 824380 [details]
File: nmcli_dev_list
Comment 6 Petr Sklenar 2013-11-15 04:35:49 EST
Created attachment 824381 [details]
File: os_info
Comment 7 Petr Sklenar 2013-11-15 04:35:52 EST
Created attachment 824382 [details]
File: program.log
Comment 8 Petr Sklenar 2013-11-15 04:35:56 EST
Created attachment 824383 [details]
File: storage.log
Comment 9 Petr Sklenar 2013-11-15 04:36:00 EST
Created attachment 824384 [details]
File: syslog
Comment 10 Petr Sklenar 2013-11-15 04:36:04 EST
Created attachment 824385 [details]
File: ifcfg.log
Comment 11 Petr Sklenar 2013-11-15 04:36:08 EST
Created attachment 824386 [details]
File: packaging.log
Comment 13 David Cantrell 2013-12-16 14:58:43 EST
I was not able to reproduce this error, but I did get another error (I was expecting an error at that point because I was really trying to yank storage out from under anaconda).  I'm going to keep this one open for now, but I'm moving it to 7.1.
Comment 14 David Lehman 2013-12-16 15:19:11 EST

*** This bug has been marked as a duplicate of bug 1029628 ***

Note You need to log in before you can comment on or make changes to this bug.