Bug 1030856 - gnumeric selection artefacts
gnumeric selection artefacts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
:
: 1013154 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 04:55 EST by moondrake
Modified: 2013-11-23 22:36 EST (History)
4 users (show)

See Also:
Fixed In Version: goffice-0.10.8-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 22:36:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of bug (161.11 KB, image/jpeg)
2013-11-15 04:55 EST, moondrake
no flags Details
another manifestation of bug (153.28 KB, image/jpeg)
2013-11-15 04:57 EST, moondrake
no flags Details

  None (edit)
Description moondrake 2013-11-15 04:55:52 EST
Created attachment 824390 [details]
screenshot of bug

Gnumeric has (for me) always been a little bit sensitive to various visual artefacts. The latest version is particularly hard to use however:

Selection boxes are not visible for the first 10 displayed rows (so if scrolled down in a sheet to a position where the window starts with 30, the problem affects row 30-40).

A screenshot is attached. The problem also affects dragging down a selection to fill a column or row, attached a screenshot where I tried to drag down 3 cells to fill the column. Only at the very bottom (row 56) a small dashed line in a corner appears (it should clearly surround the whole area from 43 to 56. Dragging it down further may eventually show the dashed line on the right-side of the column correctly. Left side is still left undashed.


This is on an updated fc20, intel driver, under kde (disabling of desktop effects has no effect on the bug)

Similar bug described here:
https://bugs.mageia.org/show_bug.cgi?id=10910
Comment 1 moondrake 2013-11-15 04:57:08 EST
Created attachment 824391 [details]
another manifestation of bug
Comment 2 M Welinder 2013-11-15 13:08:58 EST
If you're really lucky, then this is a gtk+ behaviour change as discussed
and worked around in https://bugzilla.gnome.org/show_bug.cgi?id=709320
That fix was in 1.12.8

If not, then I have no idea.



(https://bugs.mageia.org/show_bug.cgi?id=10910 was a similar problem
to https://bugzilla.gnome.org/show_bug.cgi?id=709320)
Comment 3 M Welinder 2013-11-15 13:10:22 EST
The commit that fixed upstream 709320 was

https://git.gnome.org/browse/gnumeric/commit/?id=26f0e905a1d69feb7367aff57f48bb43683b325e
Comment 4 Julian Sikorski 2013-11-15 13:16:48 EST
Can you try this build:
https://koji.fedoraproject.org/koji/buildinfo?buildID=471585
Looks like I built everything but forgot to prepare an update.
Comment 5 Julian Sikorski 2013-11-15 13:20:39 EST
Sorry, wrong link. Correct one:
https://koji.fedoraproject.org/koji/buildinfo?buildID=471582
Comment 6 moondrake 2013-11-18 14:16:09 EST
I updated my machine following latest fc20 branch today, and it seems to have been fixed. I cannot check atm whether it is the same rpm as linked above, but I think this has been fixed (cannot seem to close the bug as fixed though).
Comment 7 Julian Sikorski 2013-11-19 13:07:10 EST
Can you try doing
# yum downgrade gnumeric
and see if the bug comes back to verify?
Comment 8 moondrake 2013-11-20 08:46:23 EST
Removed:
  gnumeric.x86_64 1:1.12.8-1.fc20                                                                                                                  

Installed:
  gnumeric.x86_64 1:1.12.7-1.fc20    

I can confirm that the bug did reappear with 1.12.7
Comment 9 Fedora Update System 2013-11-21 15:09:40 EST
goffice-0.10.8-1.fc20, gnumeric-1.12.8-1.fc20, gnome-chemistry-utils-0.14.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-21448/goffice-0.10.8-1.fc20,gnumeric-1.12.8-1.fc20,gnome-chemistry-utils-0.14.3-2.fc20
Comment 10 Steven Usdansky 2013-11-22 17:02:58 EST
*** Bug 1013154 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2013-11-23 22:36:45 EST
goffice-0.10.8-1.fc20, gnumeric-1.12.8-1.fc20, gnome-chemistry-utils-0.14.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.