Bug 103094 - modprobe -r hangs unloading ip_nat_ftp when stopping iptables when there are ftp connections
modprobe -r hangs unloading ip_nat_ftp when stopping iptables when there are ...
Status: CLOSED DUPLICATE of bug 99057
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-26 11:34 EDT by Bill Cronin
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Cronin 2003-08-26 11:34:48 EDT
Description of problem:
When stopping iptables with ip_nat_ftp loaded and there are ftp connections, 
the session stopping 

[root@shopping root]# service iptables start
Applying iptables firewall rules:                          [  OK  ]
Loading additional iptables modules: ip_nat_ftp            [  OK  ]
[root@shopping root]# service iptables stop
Flushing firewall rules:                                   [  OK  ]
Setting chains to policy ACCEPT: filter nat                [  OK  ]
Unloading iptables modules:

Session hangs here, server still accessable with 1 CPU pegged at 99.9%

[root@shopping root]# ps -ef | grep modprobe
root      2310  2240 99 10:40 pts/0    00:02:06 modprobe -r ip_nat_ftp
root      2415  2327  0 10:42 pts/2    00:00:00 grep modprobe
[root@shopping root]# kill 2240
[root@shopping root]# ps -ef | grep modprobe
root      2310     1 99 10:40 pts/0    00:02:57 modprobe -r ip_nat_ftp
root      2429  2327  0 10:43 pts/2    00:00:00 grep modprobe
[root@shopping root]# kill -s 9 2310
[root@shopping root]# kill -9 2310
[root@shopping root]# ps -ef | grep modprobe
root      2310     1 99 10:40 pts/0    00:03:17 modprobe -r ip_nat_ftp
root      2431  2327  0 10:43 pts/2    00:00:00 grep modprobe

Process 2310 seems unkillable.  Reboot required to get rid of it


Version-Release number of selected component (if applicable):
[root@shopping root]# rpm -qa | grep modutil
modutils-2.4.18-3.7x
[root@shopping root]# rpm -qa | grep kern
kernel-smp-2.4.20-20.7
[root@shopping root]# rpm -qa | grep iptables
iptables-1.2.8-8.72.3


How reproducible:
Every time.

Steps to Reproduce:
1.Load/Start iptables with ip_nat_ftp as an extra module
2.Make an FTP connection
3.Unload/Stop iptables

    
Actual results:
I was left with an unkillable process taking all the CPU.

Expected results:
I would not be left with an unkillable process taking all the CPU.  ip_nat_ftp 
would unload.

Additional info:
Comment 1 Bill Nottingham 2003-08-26 11:39:55 EDT

*** This bug has been marked as a duplicate of 99057 ***
Comment 2 mediaforest 2006-01-31 07:36:20 EST
I've got exactly the same problem on a fedora 3, so I think it's not resolved yet
Comment 3 Red Hat Bugzilla 2006-02-21 13:58:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.