Bug 99057 - modprobe -r fails to unload modules, causes hang on reboot or iptables stop/restart
modprobe -r fails to unload modules, causes hang on reboot or iptables stop/r...
Status: CLOSED DUPLICATE of bug 103177
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Miller
Brian Brock
: 103094 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
Reported: 2003-07-13 08:49 EDT by Nils Philippsen
Modified: 2007-04-18 12:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gzipped strace of /etc/rc.d/initd.d/iptables stop (135.54 KB, application/octet-stream)
2003-07-14 02:22 EDT, Nils Philippsen
no flags Details
lsmod output after trying to stop iptables (2.48 KB, text/plain)
2003-07-14 02:23 EDT, Nils Philippsen
no flags Details
dmesg output after trying to stop iptables (15.14 KB, text/plain)
2003-07-14 02:24 EDT, Nils Philippsen
no flags Details

  None (edit)
Description Nils Philippsen 2003-07-13 08:49:40 EDT
Description of problem:

The new iptables init script calls modprobe -r to unload modules when stopping.
Unfortunately this causes a hang at "modprobe -r" (with e.g. the ipt_state
module) after e.g. "service iptables restart":

nils@wombat:~> sudo service iptables restart
Flushing firewall rules:                                   [  OK  ]
Setting chains to ACCEPT policy:                           [  OK  ]
Unloading iptables modules:Terminated [<-- had to kill script here]
nils@wombat:~> sudo su -
root@wombat:~> lsmod |grep ipt
iptable_filter          2444   0  (autoclean)
ip_tables              15264   1  [iptable_filter]
root@wombat:~> ps auxw|grep mod
nils      2336  0.0  1.3 17732 7032 ?        S    14:34   0:00
--oaf-activate-iid=OAFIID:GNOME_ModemLightsApplet_Factory --oaf-ior-fd=26
root      2847 91.0  0.1  3348  824 pts/3    R    14:36   4:38 modprobe -r ipt_state
root      3370  0.0  0.1  4660  668 pts/3    S    14:41   0:00 grep mod
root@wombat:~> lsmod|grep ipt_stat

As you can see, modprobe apparently goes into an endless loop even after
successfully removing the module as per "lsmod" (I also had it looping with the
module to be removed listed as "(deleted)", but that was with a kernel from RHL9).

Version-Release number of selected component (if applicable):

kernel-2.4.21-20.1.2024.2.1.nptl   (module gets removed in "lsmod")
kernel-2.4.20-18.9                 (module is "(deleted)" in "lsmod")

How reproducible:


Steps to Reproduce:
1. Boot system
2. Start iptables
3. Stop iptables
Actual results:

See above

Expected results:

Modules get unloaded, iptables script doesn't hang.
Comment 1 Nils Philippsen 2003-07-13 08:55:13 EDT
Forget about differences between the two kernels, in fact with both of them the
"ip_conntrack" module is marked as "(deleted)" (not "ipt_state").
Comment 2 Bill Nottingham 2003-07-14 00:18:11 EDT
lsmod output? Anything in dmesg?

What does strace of modprobe show?
Comment 3 Nils Philippsen 2003-07-14 02:20:44 EDT
I thought the problem had vanished because shutting down the machine worked
yesterday evening (with iptables-1.2.8-7.1), but I managed to do it again...

I'll attach strace, dmesg, lsmod output (dmesg doesn't reveal anything to me,
just the occasional cipe messages, iptables log lines...).
Comment 4 Nils Philippsen 2003-07-14 02:22:47 EDT
Created attachment 92904 [details]
gzipped strace of /etc/rc.d/initd.d/iptables stop

made it with:

strace -o $file -Ff -s 512 /etc/init.d/iptables stop
Comment 5 Nils Philippsen 2003-07-14 02:23:58 EDT
Created attachment 92905 [details]
lsmod output after trying to stop iptables
Comment 6 Nils Philippsen 2003-07-14 02:24:51 EDT
Created attachment 92906 [details]
dmesg output after trying to stop iptables
Comment 7 Nils Philippsen 2003-07-14 02:27:35 EDT
the PID of the "guilty" modprobe process ("modprobe -r ip_conntrack_ftp") is
6281, it seems to hang/loop in "delete_module".
Comment 8 Bill Nottingham 2003-07-14 11:28:04 EDT
Hanging in delete_module sounds like a kernel problem.
Comment 9 Need Real Name 2003-08-25 10:28:48 EDT
I've seen the same symptoms in 2.4.20-18.7smp.
Comment 10 Bill Nottingham 2003-08-26 11:39:57 EDT
*** Bug 103094 has been marked as a duplicate of this bug. ***
Comment 11 Nils Philippsen 2003-09-19 05:49:32 EDT
The problem doesn't show in kernel-2.4.22-1.2051.nptl -- shall I close the bug
or push this back to RHL9 -- it still shows with its kernels.
Comment 12 Dave Jones 2003-09-19 07:03:03 EDT

*** This bug has been marked as a duplicate of 103177 ***
Comment 13 mediaforest 2006-01-31 07:36:41 EST
I've got exactly the same problem on a fedora 3, so I think it's not resolved yet
Comment 14 Red Hat Bugzilla 2006-02-21 13:57:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.