Bug 1030985 - dnf distro-sync doesn't work for packages
dnf distro-sync doesn't work for packages
Status: CLOSED DUPLICATE of bug 963710
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 07:53 EST by Jaroslav Škarvada
Modified: 2013-11-18 02:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-18 02:33:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2013-11-15 07:53:11 EST
Description of problem:
dnf distro-sync doesn't work for packages. This worked in yum and can be handy e.g. during development to return the package to its distro version. One doesn't need to think whether update or downgrade is needed.

Version-Release number of selected component (if applicable):
dnf-0.4.7-1.fc20.noarch

How reproducible:
always

Steps to Reproduce:
1. dnf distro-sync acpid

Actual results:
distro-sync accepts no package specs.

Expected results:
Sync of acpid to its distro version.

Additional info:
This works in yum:
# yum distro-sync acpid
...upgrade or downgrade is performed if needed
Comment 1 Ales Kozumplik 2013-11-18 02:33:55 EST
Hi Jaroslav, you're the second person to request this --- see bug 963710.

*** This bug has been marked as a duplicate of bug 963710 ***

Note You need to log in before you can comment on or make changes to this bug.