Bug 963710 - RFE: allow package specs for distro-sync
RFE: allow package specs for distro-sync
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Silhan
Fedora Extras Quality Assurance
:
: 1030985 1077099 (view as bug list)
Depends On:
Blocks: 871892 908764
  Show dependency treegraph
 
Reported: 2013-05-16 08:42 EDT by Jan Synacek
Modified: 2014-03-25 04:13 EDT (History)
4 users (show)

See Also:
Fixed In Version: dnf-0.4.19-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-25 04:13:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Synacek 2013-05-16 08:42:19 EDT
Description of problem:

Currently, dnf doesn't allow package specs when using the distro-sync command.

# dnf distro-sync <package>
distro-sync accepts no package specs.

It would be nice if it did, as that functionality is very useful.
Comment 1 Ales Kozumplik 2013-05-17 01:41:54 EDT
hello,

yes indeed this is missing and a part of the backlog. it is unfortunately not as straightforward as it might seem given we do a "global" distro-sync already.
Comment 2 Ales Kozumplik 2013-11-18 02:33:55 EST
*** Bug 1030985 has been marked as a duplicate of this bug. ***
Comment 3 Ales Kozumplik 2013-11-18 11:35:19 EST
(to properly emulate what yum is doing, if we want to do that, we might need to use SOLVER_TARGETED when using the *_to() methods in hawkey with SOLVER_DISTUPGRADE)
Comment 4 Ales Kozumplik 2014-02-26 11:38:03 EST
Moving to Jan. Jan, mls tells me this is supported in libsolv just like other jobs (update, install). Please take a look, it will require extending hawkey which should be done in a way consistent to the other commands.
Comment 5 Jan Silhan 2014-03-10 11:55:00 EDT
The feature is available in the upstream.
Comment 6 Ales Kozumplik 2014-03-17 05:06:11 EDT
*** Bug 1077099 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2014-03-17 05:45:29 EDT
dnf-0.4.18-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.18-1.fc20
Comment 8 Fedora Update System 2014-03-18 04:10:37 EDT
Package dnf-0.4.18-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.18-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3999/dnf-0.4.18-1.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2014-03-24 05:05:58 EDT
dnf-0.4.19-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.19-1.fc20
Comment 10 Fedora Update System 2014-03-25 04:13:36 EDT
dnf-0.4.19-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.