Bug 1031110 - FC18 -> FC20: insufficient disk space need 8M free on / (1.6G free)
FC18 -> FC20: insufficient disk space need 8M free on / (1.6G free)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 1028547 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 11:04 EST by Ben Noordhuis
Modified: 2013-12-22 00:35 EST (History)
3 users (show)

See Also:
Fixed In Version: fedup-0.8.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:23:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Noordhuis 2013-11-15 11:04:28 EST
Apologies if this has been reported before.  I suspect that I'm not the first one to run into this but my searches didn't turn up anything.  Here goes:

Trying to upgrade from FC18 to FC20 fails with the following error:

<package downloads elided>
testing upgrade transaction
rpm transaction 100% [========================================================================================================================]

Upgrade test failed with the following problems:
insufficient disk space
  need 8M free on / (1.6G free)
fedup ERROR: Upgrade test failed.
rpm transaction 100% [========================================================================================================================]

The affected system indeed has 1.6G free:

# df -h
Filesystem               Size  Used Avail Use% Mounted on
devtmpfs                 2.0G     0  2.0G   0% /dev
tmpfs                    2.0G     0  2.0G   0% /dev/shm
tmpfs                    2.0G  2.3M  2.0G   1% /run
tmpfs                    2.0G     0  2.0G   0% /sys/fs/cgroup
/dev/mapper/fedora-root   20G   17G  1.6G  92% /
tmpfs                    2.0G  388K  2.0G   1% /tmp
/dev/sda1                477M  128M  320M  29% /boot

# yum --enablerepo=updates-testing install fedup
Loaded plugins: auto-update-debuginfo
Package fedup-0.7.3-4.fc18.noarch already installed and latest version
Nothing to do

It looks like either the free space check is off or fedup is telling me that 1.6G is not enough for an upgrade but reports the wrong number (e.g. that 8M is really 8G.)
Comment 1 Ben Noordhuis 2013-11-15 16:55:25 EST
Looks like fedup is indeed complaining that there's not enough free disk space but misreporting the numbers.  After freeing up some space and running fedup again, the upgrade completed smoothly.
Comment 2 Will Woods 2013-12-06 16:07:11 EST
*** Bug 1028547 has been marked as a duplicate of this bug. ***
Comment 3 Will Woods 2013-12-06 16:09:42 EST
The message should be clearer in fedup-0.8.0, e.g.:

insufficient disk space:
  / needs 36M more free space
Comment 4 Fedora Update System 2013-12-11 17:13:07 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 5 Fedora Update System 2013-12-11 17:21:12 EST
fedup-0.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc20
Comment 6 Fedora Update System 2013-12-11 17:23:02 EST
fedup-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc18
Comment 7 Fedora Update System 2013-12-13 00:10:38 EST
Package fedup-0.8.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.8.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23316/fedup-0.8.0-3.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-12-19 02:23:07 EST
fedup-0.8.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-12-19 20:45:16 EST
fedup-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-12-22 00:35:29 EST
fedup-0.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.