Bug 1031222 - hard coded limit of 64 masters in agreement and changelog code
hard coded limit of 64 masters in agreement and changelog code
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: mreynolds
Sankar Ramalingam
:
Depends On:
Blocks: 1031223 1061410
  Show dependency treegraph
 
Reported: 2013-11-15 18:04 EST by Nathan Kinder
Modified: 2014-10-14 03:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: 389-ds-base-1.2.11.15-34.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1031223 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:52:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2013-11-15 18:04:13 EST
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47587

repl5.h:
#define MAX_NUM_OF_MASTERS		64

repl5_agmt.c:
typedef struct repl5agmt {
...
	struct changecounter *changecounters[MAX_NUM_OF_MASTERS]; /* changes sent/skipped since server start up */
...
}

cl5_cache.c:
struct clc_buffer {
...
	struct csn_seq_ctrl_block *buf_cscbs [MAX_NUM_OF_MASTERS];
}
Comment 2 Milan Kubík 2014-08-14 07:02:18 EDT
Hi,

how to verify this change?

Thanks.
Comment 3 Rich Megginson 2014-08-15 10:41:23 EDT
(In reply to Milan Kubík from comment #2)
> Hi,
> 
> how to verify this change?
> 
> Thanks.

Not sure.  Mark worked on this.
Comment 4 Milan Kubík 2014-08-22 09:17:07 EDT
Taking steps from bug1031223.
Comment 5 mreynolds 2014-09-01 09:20:13 EDT
(In reply to Milan Kubík from comment #2)
> Hi,
> 
> how to verify this change?
> 
> Thanks.

Hi Milan, sorry for not getting back to you sooner.

First, I thought Sankar automated this test, so might want to check with him.

To verify it you need to create more than 64 "master" instances and over 64 agreements on one master.  You should be able to just use one of the masters to add the 64+ agreements that point to the other master replica servers - so you don't need 64+ agreements on every master, just one.  Finally, make sure replication works across all the replicas.
Comment 7 errata-xmlrpc 2014-10-14 03:52:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1385.html

Note You need to log in before you can comment on or make changes to this bug.