Bug 1031223 - hard coded limit of 64 masters in agreement and changelog code
hard coded limit of 64 masters in agreement and changelog code
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Rich Megginson
Sankar Ramalingam
:
Depends On: 1031222
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 18:05 EST by Nathan Kinder
Modified: 2014-06-17 23:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.1.6-12.el7
Doc Type: Bug Fix
Doc Text:
Cause: Need for more than 64 replication masters. Consequence: Not able to use more than 64 masters Fix: Allow unlimited number of masters. Result: Replication deployments can now use as many master as needed.
Story Points: ---
Clone Of: 1031222
Environment:
Last Closed: 2014-06-13 08:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan Kinder 2013-11-15 18:05:08 EST
+++ This bug was initially created as a clone of Bug #1031222 +++

This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/47587

repl5.h:
#define MAX_NUM_OF_MASTERS		64

repl5_agmt.c:
typedef struct repl5agmt {
...
	struct changecounter *changecounters[MAX_NUM_OF_MASTERS]; /* changes sent/skipped since server start up */
...
}

cl5_cache.c:
struct clc_buffer {
...
	struct csn_seq_ctrl_block *buf_cscbs [MAX_NUM_OF_MASTERS];
}
Comment 1 Sankar Ramalingam 2013-11-25 12:41:02 EST
Request you to add steps to verify buzilla.
Comment 3 mreynolds 2013-12-11 12:35:09 EST
Not sure how easy this is to reproduce, as you need to set up more than 64 master directory servers.

Steps:

[1]  Create 65 servers
[2]  Setup MMR replication between all of them
[3]  Verify replication is working between all the servers
Comment 5 Sankar Ramalingam 2014-02-07 08:34:10 EST
Adding qe_test_coverage+ flag
Comment 6 Ludek Smid 2014-06-13 08:08:03 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.