Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1031242 - [abrt] python-boto-2.13.3-1.fc19: key.py:849:sender:S3ResponseError: S3ResponseError: 403 Forbidden
[abrt] python-boto-2.13.3-1.fc19: key.py:849:sender:S3ResponseError: S3Respon...
Status: CLOSED DUPLICATE of bug 821799
Product: Fedora
Classification: Fedora
Component: python-boto (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:90273434aeae2bcd7686d0620ea...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 22:37 EST by Robert Sigler
Modified: 2014-08-22 17:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-22 17:03:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (19.72 KB, text/plain)
2013-11-15 22:37 EST, Robert Sigler
no flags Details
File: environ (3.11 KB, text/plain)
2013-11-15 22:38 EST, Robert Sigler
no flags Details

  None (edit)
Description Robert Sigler 2013-11-15 22:37:50 EST
Description of problem:
Attempted to put (/usr/bin/s3put) an s3 object with creds which did not allow the action.

Version-Release number of selected component:
python-boto-2.13.3-1.fc19

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/s3put -r -a xxxxxx -s xxxx -b bucket-backups -p /home/rsigler/test2/ -k stash2 home@home.rsigler.test2.tar.xz
executable:     /usr/bin/s3put
kernel:         3.11.7-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
#1 sender in /usr/lib/python2.7/site-packages/boto/s3/key.py:849
#2 _mexe in /usr/lib/python2.7/site-packages/boto/connection.py:863
#3 make_request in /usr/lib/python2.7/site-packages/boto/connection.py:972
#4 make_request in /usr/lib/python2.7/site-packages/boto/s3/connection.py:547
#5 _send_file_internal in /usr/lib/python2.7/site-packages/boto/s3/key.py:905
#6 send_file in /usr/lib/python2.7/site-packages/boto/s3/key.py:722
#7 set_contents_from_file in /usr/lib/python2.7/site-packages/boto/s3/key.py:1237
#8 set_contents_from_filename in /usr/lib/python2.7/site-packages/boto/s3/key.py:1306
#9 singlepart_upload in /usr/bin/s3put:218
#10 main in /usr/bin/s3put:374
Comment 1 Robert Sigler 2013-11-15 22:37:57 EST
Created attachment 824789 [details]
File: backtrace
Comment 2 Robert Sigler 2013-11-15 22:38:00 EST
Created attachment 824790 [details]
File: environ
Comment 3 Fedora Admin XMLRPC Client 2014-01-02 16:27:27 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Garrett Holmstrom 2014-08-22 17:03:20 EDT

*** This bug has been marked as a duplicate of bug 821799 ***

Note You need to log in before you can comment on or make changes to this bug.