Bug 1031250 - Review Request: librcd - Library for autodetection charset of Russian and Ukrainian text
Review Request: librcd - Library for autodetection charset of Russian and Ukr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mario Blättermann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-16 01:39 EST by Ivan Romanov
Modified: 2015-05-04 15:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: librcd-0.1.14-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 23:29:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mario.blaettermann: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Ivan Romanov 2013-11-16 01:39:53 EST
Spec URL: https://raw.github.com/drizt/librcd-package/b37fb1b8796917ce9c58c993a8d92d1c98b77f7e/librcd.spec
SRPM URL: https://raw.github.com/drizt/librcd-package/b37fb1b8796917ce9c58c993a8d92d1c98b77f7e/librcd-0.1.14-1.fc19.src.rpm
Description:
LibRCD is used by RusXMMS project for encoding auto-detection. It is optimized
to handle very short titles, like ID3 tags, file names and etc, and provides
very high accuracy even for short 3-4 letter words. Current version supports
Russian and Ukrainian languages and able to distinguish UTF-8, KOI8-R, CP1251,
CP866, ISO8859-1. If compared with Enca, LibRCC provides better detection
accuracy on short titles and is able to detect ISO8859-1 (non-cyrillic)
encoding what allows to properly display correct ID3 v.1 titles.

Fedora Account System Username: ivanromanov
Comment 1 Ivan Romanov 2013-11-16 01:55:05 EST
Koji scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=6187356
Comment 2 Mario Blättermann 2013-11-16 10:19:39 EST
$ rpmlint -i -v *
librcd.src: I: checking
librcd.src: W: spelling-error Summary(en_US) autodection -> detection
The value of this tag appears to be misspelled. Please double-check.

librcd.src: W: spelling-error Summary(en_US) charset -> char set, char-set, catharses
The value of this tag appears to be misspelled. Please double-check.

librcd.src: W: spelling-error %description -l en_US cyrillic -> Cyrillic
The value of this tag appears to be misspelled. Please double-check.

librcd.src: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd.src: I: checking-url http://dside.dyndns.org/files/rusxmms/librcd-0.1.14.tar.bz2 (timeout 10 seconds)
librcd.armv7hl: I: checking
librcd.armv7hl: W: spelling-error Summary(en_US) autodection -> detection
The value of this tag appears to be misspelled. Please double-check.

librcd.armv7hl: W: spelling-error Summary(en_US) charset -> char set, char-set, catharses
The value of this tag appears to be misspelled. Please double-check.

librcd.armv7hl: W: spelling-error %description -l en_US cyrillic -> Cyrillic
The value of this tag appears to be misspelled. Please double-check.

librcd.armv7hl: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd.i686: I: checking
librcd.i686: W: spelling-error Summary(en_US) autodection -> detection
The value of this tag appears to be misspelled. Please double-check.

librcd.i686: W: spelling-error Summary(en_US) charset -> char set, char-set, catharses
The value of this tag appears to be misspelled. Please double-check.

librcd.i686: W: spelling-error %description -l en_US cyrillic -> Cyrillic
The value of this tag appears to be misspelled. Please double-check.

librcd.i686: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd.x86_64: I: checking
librcd.x86_64: W: spelling-error Summary(en_US) autodection -> detection
The value of this tag appears to be misspelled. Please double-check.

librcd.x86_64: W: spelling-error Summary(en_US) charset -> char set, char-set, catharses
The value of this tag appears to be misspelled. Please double-check.

librcd.x86_64: W: spelling-error %description -l en_US cyrillic -> Cyrillic
The value of this tag appears to be misspelled. Please double-check.

librcd.x86_64: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
(none): E: no installed packages by name librcd-0.1.14.tar.bz2
librcd-debuginfo.armv7hl: I: checking
librcd-debuginfo.armv7hl: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd-debuginfo.i686: I: checking
librcd-debuginfo.i686: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd-debuginfo.x86_64: I: checking
librcd-debuginfo.x86_64: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd-devel.armv7hl: I: checking
librcd-devel.armv7hl: W: spelling-error %description -l en_US cyrillic -> Cyrillic
The value of this tag appears to be misspelled. Please double-check.

librcd-devel.armv7hl: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd-devel.armv7hl: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

librcd-devel.i686: I: checking
librcd-devel.i686: W: spelling-error %description -l en_US cyrillic -> Cyrillic
The value of this tag appears to be misspelled. Please double-check.

librcd-devel.i686: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd-devel.i686: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

librcd-devel.x86_64: I: checking
librcd-devel.x86_64: W: spelling-error %description -l en_US cyrillic -> Cyrillic
The value of this tag appears to be misspelled. Please double-check.

librcd-devel.x86_64: I: checking-url http://rusxmms.sourceforge.net (timeout 10 seconds)
librcd-devel.x86_64: W: no-documentation
The package contains no documentation (README, doc, etc). You have to include
documentation files.

librcd.spec: I: checking-url http://dside.dyndns.org/files/rusxmms/librcd-0.1.14.tar.bz2 (timeout 10 seconds)
10 packages and 1 specfiles checked; 0 errors, 18 warnings.


Some spelling errors:

autodection > autodetection or automatic detection

cyrillic > Cyrillic (to be considered as a language name which needs to be capitalized)

You might add the ChangeLog file to the -devel package. It is not of real interest for users, but maybe for developers.



---------------------------------
key:

[+] OK
[.] OK, not applicable
[X] needs work
---------------------------------

[+] MUST: rpmlint must be run on the source rpm and all binary rpms the build produces. The output should be posted in the review.
[+] MUST: The package must be named according to the Package Naming Guidelines.
[+] MUST: The spec file name must match the base package %{name}, in the format %{name}.spec unless your package has an exemption.
[+] MUST: The package must meet the Packaging Guidelines.
[+] MUST: The package must be licensed with a Fedora approved license and meet the Licensing Guidelines.
[+] MUST: The License field in the package spec file must match the actual license.
    LGPLv2+
[+] MUST: If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package must be included in %doc.
[+] MUST: The spec file must be written in American English.
[+] MUST: The spec file for the package MUST be legible.
[+] MUST: The sources used to build the package must match the upstream source, as provided in the spec URL. Reviewers should use sha256sum for this task as it is used by the sources file once imported into git. If no upstream URL can be specified for this package, please see the Source URL Guidelines for how to deal with this.
    $ sha256sum *
    261db28bc864fd4b2d3ba88403b2e421944281e323c1e39c0e61f5160c16b664  librcd-0.1.14.tar.bz2
    261db28bc864fd4b2d3ba88403b2e421944281e323c1e39c0e61f5160c16b664  librcd-0.1.14.tar.bz2.orig

[+] MUST: The package MUST successfully compile and build into binary rpms on at least one primary architecture.
[.] MUST: If the package does not successfully compile, build or work on an architecture, then those architectures should be listed in the spec in ExcludeArch. Each architecture listed in ExcludeArch MUST have a bug filed in bugzilla, describing the reason that the package does not compile/build/work on that architecture. The bug number MUST be placed in a comment, next to the corresponding ExcludeArch line.
[+] MUST: All build dependencies must be listed in BuildRequires, except for any that are listed in the exceptions section of the Packaging Guidelines ; inclusion of those as BuildRequires is optional. Apply common sense.
[.] MUST: The spec file MUST handle locales properly. This is done by using the %find_lang macro. Using %{_datadir}/locale/* is strictly forbidden.
[+] MUST: Every binary RPM package (or subpackage) which stores shared library files (not just symlinks) in any of the dynamic linker's default paths, must call ldconfig in %post and %postun.
[+] MUST: Packages must NOT bundle copies of system libraries.
[.] MUST: If the package is designed to be relocatable, the packager must state this fact in the request for review, along with the rationalization for relocation of that specific package. Without this, use of Prefix: /usr is considered a blocker.
[+] MUST: A package must own all directories that it creates. If it does not create a directory that it uses, then it should require a package which does create that directory.
[+] MUST: A Fedora package must not list a file more than once in the spec file's %files listings. (Notable exception: license texts in specific situations)
[+] MUST: Permissions on files must be set properly. Executables should be set with executable permissions, for example.
[+] MUST: Each package must consistently use macros.
[+] MUST: The package must contain code, or permissable content.
[.] MUST: Large documentation files must go in a -doc subpackage. (The definition of large is left up to the packager's best judgement, but is not restricted to size. Large can refer to either size or quantity).
[+] MUST: If a package includes something as %doc, it must not affect the runtime of the application. To summarize: If it is in %doc, the program must run properly if it is not present.
[.] MUST: Static libraries must be in a -static package.
[+] MUST: Development files must be in a -devel package.
[+] MUST: In the vast majority of cases, devel packages must require the base package using a fully versioned dependency: Requires: %{name}%{?_isa} = %{version}-%{release}
[+] MUST: Packages must NOT contain any .la libtool archives, these must be removed in the spec if they are built.
[.] MUST: Packages containing GUI applications must include a %{name}.desktop file, and that file must be properly installed with desktop-file-install in the %install section. If you feel that your packaged GUI application does not need a .desktop file, you must put a comment in the spec file with your explanation.
[+] MUST: Packages must not own files or directories already owned by other packages. The rule of thumb here is that the first package to be installed should own the files or directories that other packages may rely upon. This means, for example, that no package in Fedora should ever share ownership with any of the files or directories owned by the filesystem or man package. If you feel that you have a good reason to own a file or directory that another package owns, then please present that at package review time. 
[+] MUST: All filenames in rpm packages must be valid UTF-8.


[.] SHOULD: If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it.
[.] SHOULD: The description and summary sections in the package spec file should contain translations for supported Non-English languages, if available.
[+] SHOULD: The reviewer should test that the package builds in mock.
    See Koji build above (which uses Mock anyway).
[+] SHOULD: The package should compile and build into binary rpms on all supported architectures.
[.] SHOULD: The reviewer should test that the package functions as described. A package should not segfault instead of running, for example.
[.] SHOULD: If scriptlets are used, those scriptlets must be sane. This is vague, and left up to the reviewers judgement to determine sanity.
[.] SHOULD: Usually, subpackages other than devel should require the base package using a fully versioned dependency.
[+] SHOULD: The placement of pkgconfig(.pc) files depends on their usecase, and this is usually for development purposes, so should be placed in a -devel pkg. A reasonable exception is that the main pkg itself is a devel tool not installed in a user runtime, e.g. gcc or gdb.
[.] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin, /usr/bin, or /usr/sbin consider requiring the package which provides the file instead of the file itself.
[.] SHOULD: your package should contain man pages for binaries/scripts. If it doesn't, work with upstream to add them where they make sense.


----------------

PACKAGE APPROVED

----------------


Please don't forget to fix the spelling warnings and maybe add the ChangeLog to the -devel package before feeding the Git repo.
Comment 3 Ivan Romanov 2013-11-16 10:41:45 EST
thanks!
Comment 4 Ivan Romanov 2013-11-16 10:53:29 EST
New Package SCM Request
=======================
Package Name: librcd
Short Description: Library for autodetection charset of Russian and Ukrainian text
Owners: ivanromanov
Branches: f18 f19 f20 el6
InitialCC:
Comment 5 Ivan Romanov 2013-11-16 11:03:19 EST
yeah I allready have corrected it in my package
Comment 6 Ivan Romanov 2013-11-16 11:07:05 EST
hm ... rpmlint says
librcd.x86_64: W: spelling-error Summary(en_US) autodetection -> auto detection, auto-detection, detection
Comment 7 Mario Blättermann 2013-11-16 11:09:35 EST
(In reply to Ivan Romanov from comment #6)
> hm ... rpmlint says
> librcd.x86_64: W: spelling-error Summary(en_US) autodetection -> auto
> detection, auto-detection, detection

Then just use that what rpmlint proposes. I would prefer "auto detection". Please don't forget to change the bug summary, as I did. If the summary in the ticket and the SCM request differ, the Git people will complain.
Comment 8 Ivan Romanov 2013-11-16 11:14:37 EST
librcd.src: W: spelling-error Summary(en_US) charset -> char set, char-set, catharses

In this case what do you prefer? char set or char-set?
Comment 9 Ivan Romanov 2013-11-16 11:16:46 EST
Hm ... I try to use wikipedia 
http://en.wikipedia.org/wiki/Autodetection
http://en.wikipedia.org/wiki/Charset
In the content you can find charset not char set and not char-set
Comment 10 Mario Blättermann 2013-11-17 11:15:19 EST
(In reply to Ivan Romanov from comment #9)
> Hm ... I try to use wikipedia 
> http://en.wikipedia.org/wiki/Autodetection
> http://en.wikipedia.org/wiki/Charset
> In the content you can find charset not char set and not char-set

Then use charset. By the way, we don't have summary and description which people could misunderstand completely, it's not that critical ;)
Comment 11 Ivan Romanov 2013-11-17 11:29:14 EST
Yeah.
Comment 12 Gwyn Ciesla 2013-11-18 08:12:49 EST
Git done (by process-git-requests).
Comment 13 Fedora Update System 2013-11-18 09:21:51 EST
librcd-0.1.14-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/librcd-0.1.14-2.fc20
Comment 14 Fedora Update System 2013-11-18 09:25:00 EST
librcd-0.1.14-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/librcd-0.1.14-2.fc19
Comment 15 Fedora Update System 2013-11-18 09:25:57 EST
librcd-0.1.14-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/librcd-0.1.14-2.fc18
Comment 16 Fedora Update System 2013-11-18 09:26:54 EST
librcd-0.1.14-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/librcd-0.1.14-2.el6
Comment 17 Fedora Update System 2013-11-18 15:18:01 EST
librcd-0.1.14-2.fc20 has been pushed to the Fedora 20 testing repository.
Comment 18 Fedora Update System 2013-11-26 23:29:30 EST
librcd-0.1.14-2.fc19 has been pushed to the Fedora 19 stable repository.
Comment 19 Fedora Update System 2013-11-26 23:40:36 EST
librcd-0.1.14-2.fc18 has been pushed to the Fedora 18 stable repository.
Comment 20 Fedora Update System 2013-12-03 16:58:05 EST
librcd-0.1.14-2.el6 has been pushed to the Fedora EPEL 6 stable repository.
Comment 21 Fedora Update System 2013-12-13 22:24:00 EST
librcd-0.1.14-2.fc20 has been pushed to the Fedora 20 stable repository.
Comment 22 Ivan Romanov 2015-05-04 08:15:49 EDT
Package Change Request
=======================
Package Name: librcd
Owners: ivanromanov
New Branches: epel7
InitialCC: ivanromanov
Comment 23 Gwyn Ciesla 2015-05-04 15:46:15 EDT
Git done (by process-git-requests).

Note You need to log in before you can comment on or make changes to this bug.